Critical
hulumi before v1.3.2 Privilege Escalation via IAM Policy
Type: advisorySources: OSV
hulumi versions before v1.3.2 contain a privilege escalation vulnerability in the weekly integration IAM policy that allows role lifecycle operations on af-e2e-* roles without sufficient boundary restrictions. Attackers with the documented principal can create persistent higher-privilege roles in the sandbox account.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-82857
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 02:48 UTC · Revision 1
Source evidence
hulumi before v1.3.2 Privilege Escalation via IAM Policy
core-osv · Original sourcePublished 31 Aug 2026, 08:46 UTC
hulumi versions before v1.3.2 contain a privilege escalation vulnerability in the weekly integration IAM policy that allows role lifecycle operations on af-e2e-* roles without sufficient boundary restrictions. Attackers with the documented principal can create persistent higher-privilege roles in the sandbox account.
osv:CVE-2026-82857
Complete source record
{
"id": "9602e50940bca8503d8879abac7d4803618947fcc323912ae00e85a4ad42ce4d",
"url": "https://osv.dev/vulnerability/CVE-2026-82857",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "hulumi before v1.3.2 Privilege Escalation via IAM Policy",
"summary": "hulumi versions before v1.3.2 contain a privilege escalation vulnerability in the weekly integration IAM policy that allows role lifecycle operations on af-e2e-* roles without sufficient boundary restrictions. Attackers with the documented principal can create persistent higher-privilege roles in the sandbox account.",
"evidence": "osv:CVE-2026-82857",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-82857",
"aliases": [
"CVE-2026-82857",
"GHSA-35qr-vx94-m5x3"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/kerberosmansour/hulumi",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "53e9bafaa3a7cabde60685453874caa27b65bfa3"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.3.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.3.2"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"v1.3.1",
"v1.3.0",
"v1.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-82857.json"
}
}
],
"modified": "2026-10-28T02:30:25.305560779Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/82xxx/CVE-2026-82857.json",
"https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-35qr-vx94-m5x3",
"https://nvd.nist.gov/vuln/detail/CVE-2026-82857",
"https://www.vulncheck.com/advisories/hulumi-before-1.3.2-privilege-escalation-via-iam-policy"
],
"provider_metadata": {
"cwe_ids": [
"CWE-269"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/82xxx/CVE-2026-82857.json"
}
},
"related_cves": [
{
"value": "CVE-2026-82857",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492022,
"published_at": "2026-08-31T08:46:30.487+00:00"
}