High
GLPI Vulnerable to Arbitrary Item Deletion via Planning Endpoint
Type: advisorySources: OSV
GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to versions 10.0.25 and 11.0.7, low privilege users with access to planning can delete any object in GLPI. Upgrade to 11.0.7 or 10.0.25 to receive a patch. As a workaround, disable delete rights for User's planning.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-42318
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 09:46 UTC · Revision 1
Source evidence
GLPI Vulnerable to Arbitrary Item Deletion via Planning Endpoint
core-osv · Original sourcePublished 3 Jun 2026, 15:17 UTC
GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to versions 10.0.25 and 11.0.7, low privilege users with access to planning can delete any object in GLPI. Upgrade to 11.0.7 or 10.0.25 to receive a patch. As a workaround, disable delete rights for User's planning.
osv:CVE-2026-42318
Complete source record
{
"id": "7bd65c27c91bed7b053c65736db87c26817c2e8b9cab9b03fdb8ec8cd3269e12",
"url": "https://osv.dev/vulnerability/CVE-2026-42318",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "GLPI Vulnerable to Arbitrary Item Deletion via Planning Endpoint",
"summary": "GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to versions 10.0.25 and 11.0.7, low privilege users with access to planning can delete any object in GLPI. Upgrade to 11.0.7 or 10.0.25 to receive a patch. As a workaround, disable delete rights for User's planning.",
"evidence": "osv:CVE-2026-42318",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-42318",
"aliases": [
"CVE-2026-42318",
"GHSA-w7mr-3vwm-2j22"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "b5cb4adb3c350521d85209d49e29e8619cdf8316"
},
{
"fixed": "0ea900cb51a37f313c733b2024bf62f6a295c271"
},
{
"introduced": "9fa6de558a9987561b80afd57a796a3fa19deee6"
},
{
"fixed": "d91722c60d7552ae96c79774793bf45d78eb9771"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "11.0.0"
},
{
"fixed": "11.0.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "9.5.0"
},
{
"fixed": "10.0.25"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
}
],
"versions": [
"11.0.6",
"11.0.5",
"11.0.4",
"11.0.3",
"11.0.2",
"11.0.1",
"11.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-42318.json"
}
}
],
"modified": "2026-10-28T02:30:27.660709359Z",
"provider": "osv",
"references": [
"https://vokecyber.com/research/cve-2026-42318-glpi-arbitrary-deletion",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42318.json",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-w7mr-3vwm-2j22",
"https://nvd.nist.gov/vuln/detail/CVE-2026-42318"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42318.json"
}
},
"related_cves": [
{
"value": "CVE-2026-42318",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 494310,
"published_at": "2026-06-03T15:17:16.756+00:00"
}