libowasp-antisamy-java — security advisory
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.
- Products
- libowasp-antisamy-java
- Affected versions
- 1.5.3+dfsg-1.1, 1.7.4-1
- Fixed versions
- 1.7.4-1
- CVEs
- CVE-2023-43643
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:50 UTC · Revision 1
Source evidence
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.
osv:DEBIAN-CVE-2023-43643
libowasp-antisamy-java
Fixed versions: Not specified
libowasp-antisamy-java
Fixed versions: 1.7.4-1
libowasp-antisamy-java
Fixed versions: 1.7.4-1
Complete source record
{
"id": "e1e9cc5ccd1e847bbbd53eaedcdb15c58d61289733f1e01652b9167b9ae44edf",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-43643",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-43643",
"summary": "AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.",
"evidence": "osv:DEBIAN-CVE-2023-43643",
"products": [
{
"name": {
"value": "libowasp-antisamy-java",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.5.3+dfsg-1.1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.4-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "libowasp-antisamy-java",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.7.4-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libowasp-antisamy-java",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.7.4-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2023-43643",
"aliases": [
"DEBIAN-CVE-2023-43643"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "libowasp-antisamy-java",
"purl": "pkg:deb/debian/libowasp-antisamy-java?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.5.3+dfsg-1.1",
"1.7.4-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-43643.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.4-1"
}
]
}
],
"package": {
"name": "libowasp-antisamy-java",
"purl": "pkg:deb/debian/libowasp-antisamy-java?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-43643.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.4-1"
}
]
}
],
"package": {
"name": "libowasp-antisamy-java",
"purl": "pkg:deb/debian/libowasp-antisamy-java?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-43643.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:06.174296526Z",
"provider": "osv",
"upstream": [
"CVE-2023-43643"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-43643"
]
},
"related_cves": [
{
"value": "CVE-2023-43643",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 455854,
"published_at": "2023-10-09T14:15:10.797+00:00"
}