Medium
Security advisory
The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-25060
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:41 UTC · Revision 1
Source evidence
The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.
osv:CVE-2019-25060
Complete source record
{
"id": "ef765bf22ea98796b5d952322fdd3a54055392cc4d1ed41038e92ff3e10f4df6",
"url": "https://osv.dev/vulnerability/CVE-2019-25060",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-25060",
"summary": "The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.",
"evidence": "osv:CVE-2019-25060",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-25060",
"aliases": [
"CVE-2019-25060",
"GHSA-w3xg-7q6m-3xwp"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wp-graphql/wp-graphql",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "f5061cbf82d0408a5bb5d6257e76d4484edbd104"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpgraphql:wpgraphql:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.3.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.3.2",
"v0.3.01",
"v0.3.0",
"v0.2.3",
"v0.2.2",
"v0.2.1",
"v0.2.0",
"v0.1.4",
"v0.1.3",
"v0.1.2",
"v0.1.1",
"v0.1.0",
"v0.0.34",
"v0.0.33",
"v0.0.32",
"v0.0.31",
"v0.0.30",
"v0.0.29",
"v0.0.28",
"v0.0.27",
"v0.0.26",
"v0.0.25",
"v0.0.24",
"v0.0.23",
"v0.0.22",
"v0.0.21",
"v0.0.20",
"v0.0.18",
"v0.0.16",
"v0.0.15",
"v0.0.14",
"v0.0.13",
"v0.0.12",
"v0.0.11",
"v0.0.10",
"v0.0.9",
"v0.0.8",
"v0.0.7",
"v0.0.6",
"0.0.5",
"0.0.3",
"0.0.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-25060.json"
}
}
],
"modified": "2026-10-20T10:50:59.946046459Z",
"provider": "osv",
"references": [
"https://github.com/wp-graphql/wp-graphql/pull/900",
"https://wpscan.com/vulnerability/393be73a-f8dc-462f-8670-f20ab89421fc"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-25060",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 382426,
"published_at": "2022-05-09T17:15:07.833+00:00"
}