Skip to content
Heist/ feed
Back to feed
High

Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

Type: advisorySources: OSV

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-54988
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 04:10 UTC · Revision 1

Source evidence

Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

core-osv · Original source

Published 20 Aug 2025, 20:08 UTC

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

osv:CVE-2025-54988
Complete source record
{
  "id": "d50f1140993920797941613a4afa4a794a50cfbacd82121c1832511080d8e3a1",
  "url": "https://osv.dev/vulnerability/CVE-2025-54988",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA",
    "summary": "Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.",
    "evidence": "osv:CVE-2025-54988",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-54988",
      "aliases": [
        "CVE-2025-54988",
        "GHSA-p72g-pv48-7w9x"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/tika",
              "type": "GIT",
              "events": [
                {
                  "introduced": "386b68b5ae87beafacfb63f33e0a9888dedb9c30"
                },
                {
                  "fixed": "c5c9d00e475d48226dfe3f80a2891bfa5426043a"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:tika:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.13"
                      },
                      {
                        "fixed": "3.2.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-54988.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:42.284634220Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2025/10/msg00030.html",
        "https://repo.maven.apache.org/maven2",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54988.json",
        "https://lists.apache.org/thread/8xn3rqy6kz5b3l1t83kcofkw0w4mmj1w",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-54988"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-611"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "1.13"
                  },
                  {
                    "last_affected": "3.2.1"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54988.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-54988",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 510135,
  "published_at": "2025-08-20T20:08:49.481+00:00"
}