Skip to content
Heist/ feed
Back to feed
UnratedFix available

phpmyadmin — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2014-9219

Cross-site scripting (XSS) vulnerability in the redirection feature in url.php in phpMyAdmin 4.2.x before 4.2.13.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter.

Products
phpmyadmin
Affected versions
Not specified
Fixed versions
4:4.2.12-2
CVEs
CVE-2014-9219
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 21:42 UTC · Revision 1

Source evidence

DEBIAN-CVE-2014-9219

core-osv · Original source

Published 8 Dec 2014, 11:59 UTC

Cross-site scripting (XSS) vulnerability in the redirection feature in url.php in phpMyAdmin 4.2.x before 4.2.13.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter.

osv:DEBIAN-CVE-2014-9219

phpmyadmin

Fixed versions: 4:4.2.12-2

phpmyadmin

Fixed versions: 4:4.2.12-2

phpmyadmin

Fixed versions: 4:4.2.12-2

Complete source record
{
  "id": "e5b0eb8384dc0eb5bf15a49264fc11324dcab2340d9864fee44cf7d7320fc51c",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-9219",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2014-9219",
    "summary": "Cross-site scripting (XSS) vulnerability in the redirection feature in url.php in phpMyAdmin 4.2.x before 4.2.13.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter.",
    "evidence": "osv:DEBIAN-CVE-2014-9219",
    "products": [
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.2.12-2",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.2.12-2",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.2.12-2",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2014-9219",
      "aliases": [
        "DEBIAN-CVE-2014-9219"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.2.12-2"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-9219.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.2.12-2"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-9219.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.2.12-2"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-9219.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T15:47:31.984043496Z",
      "provider": "osv",
      "upstream": [
        "CVE-2014-9219"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2014-9219"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2014-9219",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 414152,
  "published_at": "2014-12-08T11:59:13.233+00:00"
}