Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-16219

WordPress before 5.2.3 allows XSS in shortcode previews.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-16219
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:11 UTC · Revision 1

Source evidence

CVE-2019-16219

core-osv · Original source

Published 11 Sept 2019, 14:15 UTC

WordPress before 5.2.3 allows XSS in shortcode previews.

osv:CVE-2019-16219
Complete source record
{
  "id": "a7e708704cc6f54f20a278f835aad0fc7c8b8e509f7007c5b02d33eddec3ec3a",
  "url": "https://osv.dev/vulnerability/CVE-2019-16219",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-16219",
    "summary": "WordPress before 5.2.3 allows XSS in shortcode previews.",
    "evidence": "osv:CVE-2019-16219",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2019-16219",
      "aliases": [
        "CVE-2019-16219"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "95929621e87a8f6e3fa22f7168ecdf4b5ae9417e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.2.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-16219.json"
          }
        },
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress-develop",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "ae5255196259ce2935d701ee8c91238ddf0b335e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.2.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-16219.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:36.059316948Z",
      "provider": "osv",
      "references": [
        "https://fortiguard.com/zeroday/FG-VD-18-165",
        "https://lists.debian.org/debian-lts-announce/2019/10/msg00023.html",
        "https://seclists.org/bugtraq/2020/Jan/8",
        "https://wordpress.org/news/2019/09/wordpress-5-2-3-security-and-maintenance-release/",
        "https://wpvulndb.com/vulnerabilities/9864",
        "https://www.debian.org/security/2020/dsa-4599",
        "https://www.debian.org/security/2020/dsa-4677"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
              "cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
              "cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
            ],
            "vendor_product": "debian:debian_linux",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "8.0"
                  },
                  {
                    "last_affected": "8.0"
                  },
                  {
                    "introduced": "9.0"
                  },
                  {
                    "last_affected": "9.0"
                  },
                  {
                    "introduced": "10.0"
                  },
                  {
                    "last_affected": "10.0"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2019-16219",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 433985,
  "published_at": "2019-09-11T14:15:11.85+00:00"
}