apache-directory-api — security advisory
Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.
- Products
- apache-directory-api
- Affected versions
- 2.1.2-1, 2.1.2-2
- Fixed versions
- Not specified
- CVEs
- CVE-2026-103877
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:03 UTC · Revision 1
Source evidence
Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.
osv:DEBIAN-CVE-2026-103877
apache-directory-api
Fixed versions: Not specified
apache-directory-api
Fixed versions: Not specified
apache-directory-api
Fixed versions: Not specified
Complete source record
{
"id": "59772ced98eb9dce9550795d1aea5871f8a915691e6be93115904ad0ef7939d6",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-103877",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-103877",
"summary": "Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.",
"evidence": "osv:DEBIAN-CVE-2026-103877",
"products": [
{
"name": {
"value": "apache-directory-api",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.1.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.1.2-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "apache-directory-api",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.1.2-2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "apache-directory-api",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.1.2-2",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2026-103877",
"aliases": [
"DEBIAN-CVE-2026-103877"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apache-directory-api",
"purl": "pkg:deb/debian/apache-directory-api?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.1.2-1",
"2.1.2-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-103877.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apache-directory-api",
"purl": "pkg:deb/debian/apache-directory-api?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.1.2-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-103877.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apache-directory-api",
"purl": "pkg:deb/debian/apache-directory-api?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.1.2-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-103877.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-08T10:00:30.259300857Z",
"provider": "osv",
"upstream": [
"CVE-2026-103877"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-103877"
]
},
"related_cves": [
{
"value": "CVE-2026-103877",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98935,
"published_at": "2026-10-02T10:17:06.437+00:00"
}