Medium
Security advisory
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-5934
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 09:55 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
osv:CVE-2017-5934
Complete source record
{
"id": "364ac6d7cd1f17fdfc0e0d6aee38ab5c05a745bd5000d18cae59fa5a71fead85",
"url": "https://osv.dev/vulnerability/CVE-2017-5934",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-5934",
"summary": "Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.",
"evidence": "osv:CVE-2017-5934",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-5934",
"aliases": [
"CVE-2017-5934",
"GHSA-42fp-4hm3-j8r7",
"PYSEC-2018-47"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/moinwiki/moin-1.9",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "23f0d7279d81c502ef637bffb3a3b2c9f1fdf35c"
},
{
"fixed": "70955a8eae091cc88fd9a6e510177e70289ec024"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:moinmo:moinmoin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.9.10"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "70955a8eae091cc88fd9a6e510177e70289ec024"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.9.9"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-5934.json"
}
}
],
"modified": "2026-10-20T10:48:45.505280845Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2018/10/msg00007.html",
"https://usn.ubuntu.com/3794-1/",
"https://www.debian.org/security/2018/dsa-4318",
"https://github.com/moinwiki/moin-1.9/commit/70955a8eae091cc88fd9a6e510177e70289ec024"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*"
],
"vendor_product": "canonical:ubuntu_linux",
"extracted_events": [
{
"range": [
{
"introduced": "14.04"
},
{
"last_affected": "14.04"
},
{
"introduced": "16.04"
},
{
"last_affected": "16.04"
},
{
"introduced": "18.04"
},
{
"last_affected": "18.04"
}
],
"source": "CPE_STRING"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
},
{
"cpes": [
"cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:*",
"cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:*"
],
"vendor_product": "opensuse:leap",
"extracted_events": [
{
"range": [
{
"introduced": "15.0"
},
{
"last_affected": "15.0"
},
{
"introduced": "42.3"
},
{
"last_affected": "42.3"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-5934",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 380327,
"published_at": "2018-10-15T19:29:00.507+00:00"
}