Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-21297

Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. The vulnerability is patched in the 1.2.8 release. A workaround is to ensure only authorized users are able to access the editor url.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-21297
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:14 UTC · Revision 1

Source evidence

CVE-2021-21297

core-osv · Original source

Published 26 Feb 2021, 17:15 UTC

Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. The vulnerability is patched in the 1.2.8 release. A workaround is to ensure only authorized users are able to access the editor url.

osv:CVE-2021-21297
Complete source record
{
  "id": "a9b81efc78ea6e4e2946f5ce3d1858e9d0eb6d8fd618b78fabee8a7063abd92b",
  "url": "https://osv.dev/vulnerability/CVE-2021-21297",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-21297",
    "summary": "Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. The vulnerability is patched in the 1.2.8 release. A workaround is to ensure only authorized users are able to access the editor url.",
    "evidence": "osv:CVE-2021-21297",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2021-21297",
      "aliases": [
        "CVE-2021-21297",
        "GHSA-xp9c-82x8-7f67"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/node-red/node-red",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "23f0cd3a2610c68688ea1f04fd61e9b8f6982166"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:nodered:node-red:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.2.8"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "23f0cd3a2610c68688ea1f04fd61e9b8f6982166"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "1.2.8"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.2.7",
            "1.2.6",
            "1.2.5",
            "1.2.4",
            "1.2.3",
            "1.2.0",
            "1.2.2",
            "1.2.1",
            "1.2.0-beta.1",
            "1.1.1",
            "1.1.0",
            "1.0.6",
            "1.0.5",
            "1.0.1",
            "1.0.0",
            "1.0.0-beta.4",
            "1.0.0-beta.3",
            "0.20.7",
            "0.20.6",
            "0.20.5",
            "0.20.4",
            "0.20.3",
            "0.20.2",
            "0.20.1",
            "0.20.0",
            "0.20.0-beta.5",
            "0.20.0-beta.3",
            "0.20.0-beta.2",
            "0.18.7",
            "0.18.6",
            "0.18.5",
            "0.18.4",
            "0.18.3",
            "0.18.2",
            "0.18.1",
            "0.18.0",
            "0.17.5",
            "0.17.4",
            "0.17.3",
            "0.17.2",
            "0.17.1",
            "0.17.0",
            "0.16.1",
            "0.16.0",
            "0.15.3",
            "0.15.2",
            "0.15.1",
            "0.15.0",
            "0.14.6",
            "0.14.5",
            "0.14.4",
            "0.14.3",
            "0.14.2",
            "0.14.1",
            "0.14.0",
            "0.13.4",
            "0.13.3",
            "0.13.2",
            "0.13.1",
            "0.13.0",
            "0.12.5",
            "0.12.4",
            "0.12.3",
            "0.12.2",
            "0.12.1",
            "0.12.0",
            "0.11.2",
            "0.11.1",
            "0.11.0",
            "0.10.10",
            "0.10.9",
            "0.10.8",
            "0.10.6",
            "0.10.4",
            "0.10.3",
            "0.10.2",
            "0.10.1",
            "0.10.0",
            "0.9.1",
            "0.9.0",
            "0.8.1",
            "0.8.0",
            "0.7.2",
            "0.7.1",
            "0.7.0",
            "0.6.0",
            "0.5.0",
            "0.4.0",
            "0.3.0",
            "v0.2.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21297.json"
          }
        }
      ],
      "modified": "2026-10-20T10:53:33.299966099Z",
      "provider": "osv",
      "references": [
        "https://www.npmjs.com/package/%40node-red/editor-api",
        "https://www.npmjs.com/package/%40node-red/runtime",
        "https://github.com/node-red/node-red/releases/tag/1.2.8",
        "https://github.com/node-red/node-red/security/advisories/GHSA-xp9c-82x8-7f67"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-21297",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 384412,
  "published_at": "2021-02-26T17:15:12.21+00:00"
}