modsecurity — security advisory
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Products
- modsecurity
- Affected versions
- 3.0.14-1, 3.0.9-1, 3.0.9-1+deb12u1
- Fixed versions
- 3.0.14-1+deb13u1, 3.0.15-1, 3.0.9-1+deb12u2
- CVEs
- CVE-2026-42268
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:48 UTC · Revision 2
Source evidence
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
osv:DEBIAN-CVE-2026-42268
modsecurity
Fixed versions: 3.0.9-1+deb12u2
modsecurity
Fixed versions: 3.0.14-1+deb13u1
modsecurity
Fixed versions: 3.0.15-1
Complete source record
{
"id": "15c8f4fa70f1464a902d302905cc3fbd624455ba6a052f6172e6762e9c4ed77d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-42268",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-42268",
"summary": "ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.",
"evidence": "osv:DEBIAN-CVE-2026-42268",
"products": [
{
"name": {
"value": "modsecurity",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.9-1+deb12u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "3.0.9-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.0.9-1+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "modsecurity",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.14-1+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "3.0.14-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "modsecurity",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.15-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "3.0.14-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-42268",
"aliases": [
"DEBIAN-CVE-2026-42268"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.9-1+deb12u2"
}
]
}
],
"package": {
"name": "modsecurity",
"purl": "pkg:deb/debian/modsecurity?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.0.9-1",
"3.0.9-1+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-42268.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.14-1+deb13u1"
}
]
}
],
"package": {
"name": "modsecurity",
"purl": "pkg:deb/debian/modsecurity?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"3.0.14-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-42268.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.15-1"
}
]
}
],
"package": {
"name": "modsecurity",
"purl": "pkg:deb/debian/modsecurity?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"3.0.14-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-42268.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T09:47:36.380279157Z",
"provider": "osv",
"upstream": [
"CVE-2026-42268"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-42268"
]
},
"related_cves": [
{
"value": "CVE-2026-42268",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461250,
"published_at": "2026-05-12T22:16:34.337+00:00"
}