Skip to content
Heist/ feed
Back to feed
CriticalFix available

RustSec Advisory

Type: advisorySources: OSV

## Impact **Vulnerability Type**: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). **Technical Details**: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. ## Who is Impacted? * Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g., Python, Node.js, C++). * Cloud Service Providers running the library in multi-tenant environments or automated model-training pipelines. * Users processing untrusted or third-party datasets/models that may trigger malicious JIT instruction generation. Patches * Affected versions: < 0.2.8 * Patched version: 0.2.9 ## Workarounds If you cannot upgrade immediately, please consider the following mitigations: * Strict Sandboxing: Run the library within a restricted sandbox (e.g., WebAssemb

Products
rssn
Affected versions
Not specified
Fixed versions
0.2.9
CVEs
CVE-2026-30960
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 08:44 UTC · Revision 1

Source evidence

RustSec Advisory

core-osv · Original source

Published 8 Mar 2026, 12:00 UTC

## Impact **Vulnerability Type**: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). **Technical Details**: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. ## Who is Impacted? * Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g., Python, Node.js, C++). * Cloud Service Providers running the library in multi-tenant environments or automated model-training pipelines. * Users processing untrusted or third-party datasets/models that may trigger malicious JIT instruction generation. Patches * Affected versions: < 0.2.8 * Patched version: 0.2.9 ## Workarounds If you cannot upgrade immediately, please consider the following mitigations: * Strict Sandboxing: Run the library within a restricted sandbox (e.g., WebAssemb

osv:RUSTSEC-2026-0038

rssn

Fixed versions: 0.2.9

Complete source record
{
  "id": "9a51e2c00402824335afb7632dec33c11b09f3020e893eb88762bfee3d7bde56",
  "url": "https://osv.dev/vulnerability/RUSTSEC-2026-0038",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "RustSec Advisory",
    "summary": "## Impact **Vulnerability Type**: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). **Technical Details**: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. ## Who is Impacted? * Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g., Python, Node.js, C++). * Cloud Service Providers running the library in multi-tenant environments or automated model-training pipelines. * Users processing untrusted or third-party datasets/models that may trigger malicious JIT instruction generation. Patches * Affected versions: < 0.2.8 * Patched version: 0.2.9 ## Workarounds If you cannot upgrade immediately, please consider the following mitigations: * Strict Sandboxing: Run the library within a restricted sandbox (e.g., WebAssemb",
    "evidence": "osv:RUSTSEC-2026-0038",
    "products": [
      {
        "name": {
          "value": "rssn",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.2.9",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "RUSTSEC-2026-0038",
      "aliases": [
        "CVE-2026-30960",
        "GHSA-9c4h-pwmf-m6fj",
        "RUSTSEC-2026-0038"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "0.1.20"
                },
                {
                  "fixed": "0.2.9"
                }
              ]
            }
          ],
          "package": {
            "name": "rssn",
            "purl": "pkg:cargo/rssn",
            "ecosystem": "crates.io"
          },
          "database_specific": {
            "cvss": "CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H",
            "source": "https://github.com/rustsec/advisory-db/blob/osv/crates/RUSTSEC-2026-0038.json",
            "categories": [
              "code-execution",
              "memory-corruption",
              "memory-exposure",
              "privilege-escalation"
            ],
            "informational": null
          },
          "ecosystem_specific": {
            "affects": {
              "os": [],
              "arch": [],
              "functions": []
            },
            "affected_functions": null
          }
        }
      ],
      "modified": "2026-10-12T18:00:13.557711831Z",
      "provider": "osv",
      "references": [
        "https://crates.io/crates/rssn",
        "https://rustsec.org/advisories/RUSTSEC-2026-0038.html",
        "https://github.com/Apich-Organization/rssn/commit/dea11c594f39db503e84a51f1e3c2a93f8baa8eb"
      ],
      "provider_metadata": {
        "license": "CC-BY-4.0"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-30960",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 306447,
  "published_at": "2026-03-08T12:00:00+00:00"
}