High
GLPI vulnerable to enumeration of users' email addresses by unauthenticated user
Type: advisorySources: OSV
GLPI is a free asset and IT management software package. Starting in version 0.80 and prior to version 10.0.17, an unauthenticated user can use an application endpoint to check if an email address corresponds to a valid GLPI user. Version 10.0.17 fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-43416
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 17:01 UTC · Revision 1
Source evidence
GLPI vulnerable to enumeration of users' email addresses by unauthenticated user
core-osv · Original sourcePublished 18 Nov 2024, 16:27 UTC
GLPI is a free asset and IT management software package. Starting in version 0.80 and prior to version 10.0.17, an unauthenticated user can use an application endpoint to check if an email address corresponds to a valid GLPI user. Version 10.0.17 fixes the issue.
osv:CVE-2024-43416
Complete source record
{
"id": "1c7e9d84e79fc93ef0e6f56913cd6eac609fbc4815845e85e7eeb9bff0a445bd",
"url": "https://osv.dev/vulnerability/CVE-2024-43416",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "GLPI vulnerable to enumeration of users' email addresses by unauthenticated user",
"summary": "GLPI is a free asset and IT management software package. Starting in version 0.80 and prior to version 10.0.17, an unauthenticated user can use an application endpoint to check if an email address corresponds to a valid GLPI user. Version 10.0.17 fixes the issue.",
"evidence": "osv:CVE-2024-43416",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-43416",
"aliases": [
"CVE-2024-43416",
"GHSA-j8gc-xpgr-2ww7"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "6593e00bddff0b00718142b0840ee015abd76b67"
},
{
"fixed": "08ee4d266768dc1f76cb6c716d7fd118d39676d9"
},
{
"fixed": "9be1466053f829680db318f7e7e5880d2d789c6d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.80"
},
{
"fixed": "10.0.17"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "9be1466053f829680db318f7e7e5880d2d789c6d"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-43416.json"
}
}
],
"modified": "2026-10-28T02:30:37.780163471Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/43xxx/CVE-2024-43416.json",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-j8gc-xpgr-2ww7",
"https://nvd.nist.gov/vuln/detail/CVE-2024-43416",
"https://github.com/glpi-project/glpi/commit/9be1466053f829680db318f7e7e5880d2d789c6d"
],
"provider_metadata": {
"cwe_ids": [
"CWE-200"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/43xxx/CVE-2024-43416.json"
}
},
"related_cves": [
{
"value": "CVE-2024-43416",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 505087,
"published_at": "2024-11-18T16:27:06.243+00:00"
}