Skip to content
Heist/ feed
Back to feed
CriticalFix available

librelp — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-1000140

rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be exploitable a remote attacker that can connect to rsyslog and trigger a stack buffer overflow by sending a specially crafted x509 certificate.

Products
librelp
Affected versions
Not specified
Fixed versions
1.2.15-1
CVEs
CVE-2018-1000140
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:25 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-1000140

core-osv · Original source

Published 23 Mar 2018, 21:29 UTC

rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be exploitable a remote attacker that can connect to rsyslog and trigger a stack buffer overflow by sending a specially crafted x509 certificate.

osv:DEBIAN-CVE-2018-1000140

librelp

Fixed versions: 1.2.15-1

librelp

Fixed versions: 1.2.15-1

librelp

Fixed versions: 1.2.15-1

Complete source record
{
  "id": "b6f1259498e96576a97b68e7a868818a933cd2ed4472c3da66702ef008b43a08",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000140",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-1000140",
    "summary": "rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be exploitable a remote attacker that can connect to rsyslog and trigger a stack buffer overflow by sending a specially crafted x509 certificate.",
    "evidence": "osv:DEBIAN-CVE-2018-1000140",
    "products": [
      {
        "name": {
          "value": "librelp",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.2.15-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "librelp",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.2.15-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "librelp",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.2.15-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2018-1000140",
      "aliases": [
        "DEBIAN-CVE-2018-1000140"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.2.15-1"
                }
              ]
            }
          ],
          "package": {
            "name": "librelp",
            "purl": "pkg:deb/debian/librelp?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000140.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.2.15-1"
                }
              ]
            }
          ],
          "package": {
            "name": "librelp",
            "purl": "pkg:deb/debian/librelp?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000140.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.2.15-1"
                }
              ]
            }
          ],
          "package": {
            "name": "librelp",
            "purl": "pkg:deb/debian/librelp?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000140.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:17.981463117Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-1000140"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-1000140"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-1000140",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 421050,
  "published_at": "2018-03-23T21:29:00.647+00:00"
}