Skip to content
Heist/ feed
Back to feed
Low

Knowage vulnerable to server-side request forgery

Type: advisorySources: OSV

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-55007
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 08:26 UTC · Revision 1

Source evidence

Knowage vulnerable to server-side request forgery

core-osv · Original source

Published 1 Sept 2025, 15:46 UTC

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

osv:CVE-2025-55007
Complete source record
{
  "id": "328ae79c8b5b3d30aac7a2df51585d4754fc5d3adc2e272a7118885ad62a0c3d",
  "url": "https://osv.dev/vulnerability/CVE-2025-55007",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Knowage vulnerable to server-side request forgery",
    "summary": "Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.",
    "evidence": "osv:CVE-2025-55007",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2025-55007",
      "aliases": [
        "CVE-2025-55007",
        "GHSA-7f6m-ph57-52w6"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/knowagelabs/knowage-server",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "13d22c5023e2373044fb0d06a8a91b7429872c30"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "8.1.37"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "8.1.37"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v8.1.36",
            "v8.1.35",
            "v8.1.34",
            "v8.1.32",
            "v8.1.31",
            "v8.1.30",
            "v8.1.29",
            "v8.1.28",
            "v8.1.27",
            "v8.1.26",
            "v8.1.25",
            "v8.1.24",
            "v8.1.23",
            "v8.1.22",
            "v8.1.21",
            "v8.1.20",
            "v8.1.19",
            "v8.1.18",
            "v8.1.17",
            "v8.1.16",
            "v8.1.15",
            "v8.1.12",
            "v8.1.11",
            "v8.1.10",
            "v8.1.9",
            "v8.1.8",
            "v8.1.7",
            "v8.1.6",
            "v8.1.3",
            "v8.1.2",
            "v8.1.1",
            "v8.1.0",
            "v7.2.0",
            "v7.2.0-2020-04-06",
            "v7.0.0-RC"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-55007.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:27.085531500Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/55xxx/CVE-2025-55007.json",
        "https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-7f6m-ph57-52w6",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-55007"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-918"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/55xxx/CVE-2025-55007.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-55007",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 493805,
  "published_at": "2025-09-01T15:46:04.915+00:00"
}