Critical
Security advisory
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-13917
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:53 UTC · Revision 1
Source evidence
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).
osv:CVE-2019-13917
Complete source record
{
"id": "a62092ccaf517c2a7be11e9e5e56d299e1cf44d4f51182d5da9f7433d2526aec",
"url": "https://osv.dev/vulnerability/CVE-2019-13917",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-13917",
"summary": "Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).",
"evidence": "osv:CVE-2019-13917",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2019-13917",
"aliases": [
"CVE-2019-13917"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/exim/exim",
"type": "GIT",
"events": [
{
"introduced": "7fcd7cd65f514c57b0670633c4d8d9583294f6a9"
},
{
"last_affected": "ae63862ba6f6ee0c17ec865cc6cf0eebb3ca2389"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:exim:exim:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.85"
},
{
"last_affected": "4.92"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"exim-4.92-jgh",
"exim-4.92-RC6",
"exim-4.92",
"exim-4.92-RC5",
"exim-4.92-RC4",
"exim-4.92-RC3",
"exim-4.92-RC2",
"exim-4.92-RC1",
"exim-4_91",
"exim-4_91_RC4",
"exim-4_91_RC3",
"exim-4_91_RC2",
"exim-4_91_RC1",
"exim-4_90_RC4",
"exim-4_90",
"exim-4_90_RC3",
"exim-4_90_RC2",
"exim-4_90_RC1",
"exim-4.90devstart",
"exim-4_89_RC3",
"exim-4_89_RC1",
"exim-4_88",
"exim-4_87",
"exim-4_88_RC6",
"exim-4_88_RC5",
"exim-4_88_RC4",
"exim-4_88_RC3",
"exim-4_88_RC2",
"exim-4_88_RC1",
"exim-4_87_RC7",
"exim-4_87_RC6",
"exim-4_87_RC5",
"exim-4_87_RC4",
"exim-4_86",
"exim-4_85",
"exim-4_87_RC3",
"exim-4_87_RC2",
"exim-4_87_RC1",
"exim-4_86_RC5",
"exim-4_86_RC4",
"exim-4_86_RC3",
"exim-4_86_RC2",
"exim-4_86_RC1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-13917.json"
}
}
],
"modified": "2026-10-24T10:30:22.998026406Z",
"provider": "osv",
"references": [
"https://seclists.org/bugtraq/2019/Jul/51",
"https://security.gentoo.org/glsa/201909-06",
"https://www.debian.org/security/2019/dsa-4488"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
},
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-13917",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 430817,
"published_at": "2019-07-25T20:15:11.81+00:00"
}