Apache Guacamole: Improper input validation of console codes
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-35164
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 18:52 UTC · Revision 1
Source evidence
Apache Guacamole: Improper input validation of console codes
core-osv · Original sourcePublished 2 Jul 2025, 11:23 UTC
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
osv:CVE-2024-35164
Complete source record
{
"id": "d6966b35640b3b7c1d7c74ec8813ad26aeb5727d0dfe48af54ca5ba5a87bd221",
"url": "https://osv.dev/vulnerability/CVE-2024-35164",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Guacamole: Improper input validation of console codes",
"summary": "The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.",
"evidence": "osv:CVE-2024-35164",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-35164",
"aliases": [
"CVE-2024-35164"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/guacamole-server",
"type": "GIT",
"events": [
{
"introduced": "d07830ea33965182dc75d3ef3c7bcd04a51b609f"
},
{
"fixed": "1f664e08feae6e7d15d8146b78acab2e6fb470ae"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:guacamole:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.8.0"
},
{
"fixed": "1.6.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-35164.json"
}
}
],
"modified": "2026-10-28T02:30:22.384085848Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/35xxx/CVE-2024-35164.json",
"https://lists.apache.org/thread/sgs8lplbkrpvd3hrvcnnxh3028h4py70",
"https://nvd.nist.gov/vuln/detail/CVE-2024-35164"
],
"provider_metadata": {
"cwe_ids": [
"CWE-129"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "0.8.0"
},
{
"last_affected": "1.5.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/35xxx/CVE-2024-35164.json"
}
},
"related_cves": [
{
"value": "CVE-2024-35164",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 488794,
"published_at": "2025-07-02T11:23:22.75+00:00"
}