Ghost from 2.5.0 before 6.64.0 Stored XSS via oEmbed Photo Responses
Ghost from 2.5.0 before 6.64.0 contains a stored cross-site scripting vulnerability that allows attackers to inject untrusted scripts into post content via oEmbed photo responses. Attackers can host malicious oEmbed photo responses so that embedding their URL stores scripts that run in the Ghost editor, published site, and newsletter emails, compromising staff admin sessions.
- Products
- ghost
- Affected versions
- Not specified
- Fixed versions
- 6.64.0
- CVEs
- CVE-2026-104414, CVE-2026-105650
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 09:02 UTC · Revision 1
Source evidence
Ghost from 2.5.0 before 6.64.0 Stored XSS via oEmbed Photo Responses
core-osv · Original sourcePublished 9 Oct 2026, 10:45 UTC
Ghost from 2.5.0 before 6.64.0 contains a stored cross-site scripting vulnerability that allows attackers to inject untrusted scripts into post content via oEmbed photo responses. Attackers can host malicious oEmbed photo responses so that embedding their URL stores scripts that run in the Ghost editor, published site, and newsletter emails, compromising staff admin sessions.
osv:BIT-ghost-2026-104414
ghost
Fixed versions: 6.64.0
Complete source record
{
"id": "bb18655e14685c751af98aec792db96aa9a45a2220459ad0f1532b086cc78493",
"url": "https://osv.dev/vulnerability/BIT-ghost-2026-104414",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Ghost from 2.5.0 before 6.64.0 Stored XSS via oEmbed Photo Responses",
"summary": "Ghost from 2.5.0 before 6.64.0 contains a stored cross-site scripting vulnerability that allows attackers to inject untrusted scripts into post content via oEmbed photo responses. Attackers can host malicious oEmbed photo responses so that embedding their URL stores scripts that run in the Ghost editor, published site, and newsletter emails, compromising staff admin sessions.",
"evidence": "osv:BIT-ghost-2026-104414",
"products": [
{
"name": {
"value": "ghost",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.64.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "BIT-ghost-2026-104414",
"aliases": [
"BIT-ghost-2026-104414",
"BIT-ghost-2026-105650",
"CVE-2026-104414",
"CVE-2026-105650",
"GHSA-v3xr-g6p2-fvgv"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "2.5.0"
},
{
"fixed": "6.64.0"
}
]
}
],
"package": {
"name": "ghost",
"purl": "pkg:bitnami/ghost",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/ghost/BIT-ghost-2026-104414.json"
}
}
],
"modified": "2026-10-13T08:26:09.329348253Z",
"provider": "osv",
"references": [
"https://github.com/TryGhost/Ghost/security/advisories/GHSA-v3xr-g6p2-fvgv",
"https://nvd.nist.gov/vuln/detail/CVE-2026-104414",
"https://www.vulncheck.com/advisories/ghost-from-2.5.0-before-6.64.0-stored-xss-via-oembed-photo-responses"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:ghost:ghost:*:*:*:*:*:node.js:*:*"
],
"severity": "High"
}
},
"related_cves": [
{
"value": "CVE-2026-104414",
"evidence": "/aliases"
},
{
"value": "CVE-2026-105650",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 307510,
"published_at": "2026-10-09T10:45:16.216+00:00"
}