UnratedFix available
Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-010
Type: advisorySources: Drupal security
Drupal issued an advisory about a Guzzle security update that may affect contributed projects or custom code using Guzzle for outgoing requests; the announcement says it does not affect Drupal core.
- Products
- Drupal core
- Affected versions
- >= 8.0.0 <9.2.20 || >= 9.3.0 <9.3.14
- Fixed versions
- 9.2.20, 9.3.14
- CVEs
- CVE-2022-29248
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 15:23 UTC · Revision 1
Source evidence
Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-010
official-drupal-security · Original sourcePublished 25 May 2022, 19:39 UTC
Drupal issued an advisory about a Guzzle security update that may affect contributed projects or custom code using Guzzle for outgoing requests; the announcement says it does not affect Drupal core.
Guzzle has released a security update which does not affect Drupal core, but may affect some contributed projects or custom code on Drupal sites.
Drupal core
Fixed versions: 9.3.14, 9.2.20
Complete source record
{
"id": "022139e464ba4109f83e75a020dd2b3e0b6ab47b5dc244fb84d0485ddd45aed5",
"url": "https://www.drupal.org/sa-core-2022-010",
"method": "llm",
"payload": {
"kind": "advisory",
"title": "Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-010",
"summary": "Drupal issued an advisory about a Guzzle security update that may affect contributed projects or custom code using Guzzle for outgoing requests; the announcement says it does not affect Drupal core.",
"evidence": "Guzzle has released a security update which does not affect Drupal core, but may affect some contributed projects or custom code on Drupal sites.",
"products": [
{
"name": {
"value": "Drupal core",
"evidence": "Project: Drupal core"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.3.14",
"evidence": "If you are using Drupal 9.3, update to Drupal 9.3.14."
},
{
"value": "9.2.20",
"evidence": "If you are using Drupal 9.2, update to Drupal 9.2.20."
}
],
"affected_versions": [
{
"value": ">= 8.0.0 <9.2.20 || >= 9.3.0 <9.3.14",
"evidence": "Affected versions: >= 8.0.0 <9.2.20 || >= 9.3.0 <9.3.14"
}
]
}
],
"severity": "unknown",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2022-29248",
"evidence": "CVE IDs: CVE-2022-29248"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "official-drupal-security",
"document_id": 23497,
"published_at": "2022-05-25T19:39:01+00:00"
}