netty — security advisory
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.137.Final and 4.2.17.Final, MqttEncoder does not validate client identifiers, will topics, usernames, and PUBLISH topic names before encoding, allowing prohibited null bytes in MQTT UTF-8 string fields and potentially causing routing, access-control, or identity mismatches in downstream brokers. The vulnerability is exploitable when an application uses Netty's MQTT encoder to construct messages from user-controlled input. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final.
- Products
- netty
- Affected versions
- 1:4.1.48-10, 1:4.1.48-10+deb13u1, 1:4.1.48-11, 1:4.1.48-12, 1:4.1.48-13, 1:4.1.48-14, 1:4.1.48-15, 1:4.1.48-16, 1:4.1.48-7, 1:4.1.48-7+deb12u1, 1:4.1.48-7+deb12u2, 1:4.1.48-8, 1:4.1.48-9
- Fixed versions
- Not specified
- CVEs
- CVE-2026-76816
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 09:03 UTC · Revision 1
Source evidence
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.137.Final and 4.2.17.Final, MqttEncoder does not validate client identifiers, will topics, usernames, and PUBLISH topic names before encoding, allowing prohibited null bytes in MQTT UTF-8 string fields and potentially causing routing, access-control, or identity mismatches in downstream brokers. The vulnerability is exploitable when an application uses Netty's MQTT encoder to construct messages from user-controlled input. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final.
osv:DEBIAN-CVE-2026-76816
netty
Fixed versions: Not specified
netty
Fixed versions: Not specified
netty
Fixed versions: Not specified
Complete source record
{
"id": "3bd9f588e9ba8eeb95e168ada218f007bec1e2d6004a9556f85f3799551a28f8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-76816",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-76816",
"summary": "Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.137.Final and 4.2.17.Final, MqttEncoder does not validate client identifiers, will topics, usernames, and PUBLISH topic names before encoding, allowing prohibited null bytes in MQTT UTF-8 string fields and potentially causing routing, access-control, or identity mismatches in downstream brokers. The vulnerability is exploitable when an application uses Netty's MQTT encoder to construct messages from user-controlled input. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final.",
"evidence": "osv:DEBIAN-CVE-2026-76816",
"products": [
{
"name": {
"value": "netty",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:4.1.48-10",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-11",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-12",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-13",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-14",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-15",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-16",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-7",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-7+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-7+deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-8",
"evidence": "/affected/0/versions"
},
{
"value": "1:4.1.48-9",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "netty",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:4.1.48-10",
"evidence": "/affected/1/versions"
},
{
"value": "1:4.1.48-10+deb13u1",
"evidence": "/affected/1/versions"
},
{
"value": "1:4.1.48-11",
"evidence": "/affected/1/versions"
},
{
"value": "1:4.1.48-12",
"evidence": "/affected/1/versions"
},
{
"value": "1:4.1.48-13",
"evidence": "/affected/1/versions"
},
{
"value": "1:4.1.48-14",
"evidence": "/affected/1/versions"
},
{
"value": "1:4.1.48-15",
"evidence": "/affected/1/versions"
},
{
"value": "1:4.1.48-16",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "netty",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:4.1.48-10",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-11",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-12",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-13",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-14",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-15",
"evidence": "/affected/2/versions"
},
{
"value": "1:4.1.48-16",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "low",
"structured": {
"id": "DEBIAN-CVE-2026-76816",
"aliases": [
"DEBIAN-CVE-2026-76816"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "netty",
"purl": "pkg:deb/debian/netty?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1:4.1.48-10",
"1:4.1.48-11",
"1:4.1.48-12",
"1:4.1.48-13",
"1:4.1.48-14",
"1:4.1.48-15",
"1:4.1.48-16",
"1:4.1.48-7",
"1:4.1.48-7+deb12u1",
"1:4.1.48-7+deb12u2",
"1:4.1.48-8",
"1:4.1.48-9"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-76816.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "netty",
"purl": "pkg:deb/debian/netty?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1:4.1.48-10",
"1:4.1.48-10+deb13u1",
"1:4.1.48-11",
"1:4.1.48-12",
"1:4.1.48-13",
"1:4.1.48-14",
"1:4.1.48-15",
"1:4.1.48-16"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-76816.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "netty",
"purl": "pkg:deb/debian/netty?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1:4.1.48-10",
"1:4.1.48-11",
"1:4.1.48-12",
"1:4.1.48-13",
"1:4.1.48-14",
"1:4.1.48-15",
"1:4.1.48-16"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-76816.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-13T09:47:30.869910040Z",
"provider": "osv",
"upstream": [
"CVE-2026-76816"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-76816"
]
},
"related_cves": [
{
"value": "CVE-2026-76816",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 307567,
"published_at": "2026-08-24T20:17:19.477+00:00"
}