ckeditor — security advisory
ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.
- Products
- ckeditor
- Affected versions
- Not specified
- Fixed versions
- 4.16.2+dfsg-1
- CVEs
- CVE-2021-32809
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:22 UTC · Revision 1
Source evidence
ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.
osv:DEBIAN-CVE-2021-32809
ckeditor
Fixed versions: 4.16.2+dfsg-1
Complete source record
{
"id": "f900d72fee0b96305571a9d9ad69753cb6339068131989ac50d204c1952089fc",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-32809",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-32809",
"summary": "ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.",
"evidence": "osv:DEBIAN-CVE-2021-32809",
"products": [
{
"name": {
"value": "ckeditor",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.16.2+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2021-32809",
"aliases": [
"DEBIAN-CVE-2021-32809"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.16.2+dfsg-1"
}
]
}
],
"package": {
"name": "ckeditor",
"purl": "pkg:deb/debian/ckeditor?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-32809.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:14.017290439Z",
"provider": "osv",
"upstream": [
"CVE-2021-32809"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-32809"
]
},
"related_cves": [
{
"value": "CVE-2021-32809",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420881,
"published_at": "2021-08-12T17:15:08.167+00:00"
}