openssl — security advisory
The ssl3_get_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k allows remote SSL servers to conduct RSA-to-EXPORT_RSA downgrade attacks and facilitate brute-force decryption by offering a weak ephemeral RSA key in a noncompliant role, related to the "FREAK" issue. NOTE: the scope of this CVE is only client code based on OpenSSL, not EXPORT_RSA issues associated with servers or other TLS implementations.
- Products
- openssl
- Affected versions
- Not specified
- Fixed versions
- 1.0.1k-1
- CVEs
- CVE-2015-0204
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 13:01 UTC · Revision 1
Source evidence
The ssl3_get_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k allows remote SSL servers to conduct RSA-to-EXPORT_RSA downgrade attacks and facilitate brute-force decryption by offering a weak ephemeral RSA key in a noncompliant role, related to the "FREAK" issue. NOTE: the scope of this CVE is only client code based on OpenSSL, not EXPORT_RSA issues associated with servers or other TLS implementations.
osv:DEBIAN-CVE-2015-0204
openssl
Fixed versions: 1.0.1k-1
openssl
Fixed versions: 1.0.1k-1
openssl
Fixed versions: 1.0.1k-1
Complete source record
{
"id": "c75718b794cb1fd3180d1647ef9d525dde19e35e47540caf75921a4f79299924",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2015-0204",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2015-0204",
"summary": "The ssl3_get_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k allows remote SSL servers to conduct RSA-to-EXPORT_RSA downgrade attacks and facilitate brute-force decryption by offering a weak ephemeral RSA key in a noncompliant role, related to the \"FREAK\" issue. NOTE: the scope of this CVE is only client code based on OpenSSL, not EXPORT_RSA issues associated with servers or other TLS implementations.",
"evidence": "osv:DEBIAN-CVE-2015-0204",
"products": [
{
"name": {
"value": "openssl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.0.1k-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openssl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.0.1k-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openssl",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.0.1k-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2015-0204",
"aliases": [
"DEBIAN-CVE-2015-0204"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.1k-1"
}
]
}
],
"package": {
"name": "openssl",
"purl": "pkg:deb/debian/openssl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2015-0204.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.1k-1"
}
]
}
],
"package": {
"name": "openssl",
"purl": "pkg:deb/debian/openssl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2015-0204.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.1k-1"
}
]
}
],
"package": {
"name": "openssl",
"purl": "pkg:deb/debian/openssl?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2015-0204.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T01:47:44.252391495Z",
"provider": "osv",
"upstream": [
"CVE-2015-0204"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2015-0204"
]
},
"related_cves": [
{
"value": "CVE-2015-0204",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 318432,
"published_at": "2015-01-09T02:59:10.287+00:00"
}