apache2 — security advisory
The mod_proxy module in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x before 2.2.18, when the Revision 1179239 patch is in place, does not properly interact with use of (1) RewriteRule and (2) ProxyPassMatch pattern matches for configuration of a reverse proxy, which allows remote attackers to send requests to intranet servers by using the HTTP/0.9 protocol with a malformed URI containing an initial @ (at sign) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-3368.
- Products
- apache2
- Affected versions
- Not specified
- Fixed versions
- 2.2.18-1
- CVEs
- CVE-2011-3639
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:26 UTC · Revision 1
Source evidence
The mod_proxy module in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x before 2.2.18, when the Revision 1179239 patch is in place, does not properly interact with use of (1) RewriteRule and (2) ProxyPassMatch pattern matches for configuration of a reverse proxy, which allows remote attackers to send requests to intranet servers by using the HTTP/0.9 protocol with a malformed URI containing an initial @ (at sign) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-3368.
osv:DEBIAN-CVE-2011-3639
apache2
Fixed versions: 2.2.18-1
apache2
Fixed versions: 2.2.18-1
apache2
Fixed versions: 2.2.18-1
Complete source record
{
"id": "22e68e3e751f5a313836c2a7761c7e2d55e90185dd6f02c965f5414b6db2b384",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-3639",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2011-3639",
"summary": "The mod_proxy module in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x before 2.2.18, when the Revision 1179239 patch is in place, does not properly interact with use of (1) RewriteRule and (2) ProxyPassMatch pattern matches for configuration of a reverse proxy, which allows remote attackers to send requests to intranet servers by using the HTTP/0.9 protocol with a malformed URI containing an initial @ (at sign) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-3368.",
"evidence": "osv:DEBIAN-CVE-2011-3639",
"products": [
{
"name": {
"value": "apache2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.18-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apache2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.18-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apache2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.18-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2011-3639",
"aliases": [
"DEBIAN-CVE-2011-3639"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.18-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-3639.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.18-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-3639.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.18-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-3639.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:21.457666918Z",
"provider": "osv",
"upstream": [
"CVE-2011-3639"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2011-3639"
]
},
"related_cves": [
{
"value": "CVE-2011-3639",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 416475,
"published_at": "2011-11-30T04:05:58.437+00:00"
}