@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-33804
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 19:24 UTC · Revision 1
Source evidence
@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
core-osv · Original sourcePublished 16 Apr 2026, 13:56 UTC
@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.
osv:CVE-2026-33804
Complete source record
{
"id": "153cb15352f3eb0623bef33c2a3b2683be549cde1901d84bc920aa50e3b2e9a5",
"url": "https://osv.dev/vulnerability/CVE-2026-33804",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option",
"summary": "@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.",
"evidence": "osv:CVE-2026-33804",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-33804",
"aliases": [
"CVE-2026-33804",
"GHSA-v9ww-2j6r-98q6"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/fastify/middie",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "792d2f46ae68516d3122c9a4468a5748a34efb47"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "9.3.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:fastify:fastify\\/middie:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "9.3.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v9.3.1",
"v9.3.0",
"v9.2.0",
"v9.1.0",
"v9.0.3",
"v9.0.2",
"v9.0.1",
"v8.3.1",
"v9.0.0",
"v8.3.0",
"v8.2.0",
"v8.1.0",
"v8.0.0",
"v7.0.0",
"v6.0.0",
"v5.4.0",
"v5.3.0",
"v5.2.0",
"v5.1.0",
"v5.0.0",
"v4.1.0",
"v4.0.1",
"v3.2.1",
"v3.2.0",
"v4.0.0",
"v3.1.0",
"v3.0.0",
"v2.1.1",
"v2.1.0",
"v2.0.0",
"v1.1.0",
"v1.0.0",
"v0.3.0",
"v0.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-33804.json"
}
}
],
"modified": "2026-10-28T02:30:22.810876647Z",
"provider": "osv",
"references": [
"https://cna.openjsf.org/security-advisories.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/33xxx/CVE-2026-33804.json",
"https://github.com/fastify/middie/security/advisories/GHSA-v9ww-2j6r-98q6",
"https://nvd.nist.gov/vuln/detail/CVE-2026-33804"
],
"provider_metadata": {
"cwe_ids": [
"CWE-436"
],
"cna_assigner": "openjs",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/33xxx/CVE-2026-33804.json"
}
},
"related_cves": [
{
"value": "CVE-2026-33804",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 489120,
"published_at": "2026-04-16T13:56:56.176+00:00"
}