UnratedFix available
gpsd — security advisory
Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.
- Products
- gpsd
- Affected versions
- Not specified
- Fixed versions
- 2.7-4
- CVEs
- CVE-2004-1388
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 14:25 UTC · Revision 1
Source evidence
Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.
osv:DEBIAN-CVE-2004-1388
gpsd
Fixed versions: 2.7-4
gpsd
Fixed versions: 2.7-4
gpsd
Fixed versions: 2.7-4
Complete source record
{
"id": "3ef2da8b527483955e67990abe5b8e054ebfaa82753a96091d2844ac2a675e2c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2004-1388",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2004-1388",
"summary": "Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.",
"evidence": "osv:DEBIAN-CVE-2004-1388",
"products": [
{
"name": {
"value": "gpsd",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.7-4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gpsd",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.7-4",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gpsd",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.7-4",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2004-1388",
"aliases": [
"DEBIAN-CVE-2004-1388"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.7-4"
}
]
}
],
"package": {
"name": "gpsd",
"purl": "pkg:deb/debian/gpsd?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-1388.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.7-4"
}
]
}
],
"package": {
"name": "gpsd",
"purl": "pkg:deb/debian/gpsd?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-1388.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.7-4"
}
]
}
],
"package": {
"name": "gpsd",
"purl": "pkg:deb/debian/gpsd?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-1388.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-21T15:47:36.695943186Z",
"provider": "osv",
"upstream": [
"CVE-2004-1388"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2004-1388"
]
},
"related_cves": [
{
"value": "CVE-2004-1388",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 394036,
"published_at": "2004-12-31T05:00:00+00:00"
}