vllm — security advisory
vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. Attackers can submit requests with min_tokens greater than zero and out-of-vocabulary stop_token_ids to trigger CUDA tensor indexing failures that leave EngineCore in a fatal state requiring service restart.
- Products
- vllm
- Affected versions
- 0.22.0, 0.22.1, 0.23.0
- Fixed versions
- 0.24.0
- CVEs
- CVE-2026-100652
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 03:41 UTC · Revision 1
Source evidence
vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. Attackers can submit requests with min_tokens greater than zero and out-of-vocabulary stop_token_ids to trigger CUDA tensor indexing failures that leave EngineCore in a fatal state requiring service restart.
osv:PYSEC-2026-4185
vllm
Fixed versions: 0.24.0
Complete source record
{
"id": "6c70714188ed2326856a69ec95d8ec07cad43f69c51352e69e76f24e1e1bb892",
"url": "https://osv.dev/vulnerability/PYSEC-2026-4185",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "PYSEC-2026-4185",
"summary": "vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. Attackers can submit requests with min_tokens greater than zero and out-of-vocabulary stop_token_ids to trigger CUDA tensor indexing failures that leave EngineCore in a fatal state requiring service restart.",
"evidence": "osv:PYSEC-2026-4185",
"products": [
{
"name": {
"value": "vllm",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.24.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "0.22.0",
"evidence": "/affected/0/versions"
},
{
"value": "0.22.1",
"evidence": "/affected/0/versions"
},
{
"value": "0.23.0",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "PYSEC-2026-4185",
"aliases": [
"CVE-2026-100652",
"GHSA-qff2-492f-9fm4",
"PYSEC-2026-4185"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0.22.0"
},
{
"fixed": "0.24.0"
}
]
}
],
"package": {
"name": "vllm",
"purl": "pkg:pypi/vllm",
"ecosystem": "PyPI"
},
"versions": [
"0.22.0",
"0.22.1",
"0.23.0"
],
"database_specific": {
"source": "https://github.com/pypa/advisory-database/blob/main/vulns/vllm/PYSEC-2026-4185.yaml"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-07T10:00:03.378975746Z",
"provider": "osv",
"references": [
"https://www.vulncheck.com/advisories/vllm-0.22.0-through-0.23.0-denial-of-service-via-stop-token-ids",
"https://github.com/vllm-project/vllm/security/advisories/GHSA-qff2-492f-9fm4"
]
},
"related_cves": [
{
"value": "CVE-2026-100652",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 94682,
"published_at": "2026-09-26T14:16:47.81+00:00"
}