dcmtk — security advisory
A vulnerability was detected in OFFIS DCMTK up to 3.6.9. Affected by this issue is the function DcmByteString::makeDicomByteString of the file dcmdata/libsrc/dcbytstr.cc of the component dcmdata. The manipulation results in memory corruption. The attack can be launched remotely. Upgrading to version 3.7.0 can resolve this issue. The patch is identified as 4c0e5c10079392c594d6a7abd95dd78ac0aa556a. You should upgrade the affected component.
- Products
- dcmtk
- Affected versions
- 3.6.7-8, 3.6.7-9~deb12u1, 3.6.7-9~deb12u2, 3.6.7-9~deb12u3, 3.6.9-5, 3.6.9-6, 3.7.0+really3.6.9-1, 3.7.0+really3.7.0-0+exp1, 3.7.0-1
- Fixed versions
- 3.6.7-9~deb12u4, 3.6.9-5+deb13u1, 3.7.0+really3.7.0-1
- CVEs
- CVE-2025-14607
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:02 UTC · Revision 1
Source evidence
A vulnerability was detected in OFFIS DCMTK up to 3.6.9. Affected by this issue is the function DcmByteString::makeDicomByteString of the file dcmdata/libsrc/dcbytstr.cc of the component dcmdata. The manipulation results in memory corruption. The attack can be launched remotely. Upgrading to version 3.7.0 can resolve this issue. The patch is identified as 4c0e5c10079392c594d6a7abd95dd78ac0aa556a. You should upgrade the affected component.
osv:DEBIAN-CVE-2025-14607
dcmtk
Fixed versions: 3.6.7-9~deb12u4
dcmtk
Fixed versions: 3.6.9-5+deb13u1
dcmtk
Fixed versions: 3.7.0+really3.7.0-1
Complete source record
{
"id": "07849b04443a109cc51412032a59b155a79f4fae70e3e66f1bac81e5ffd3429e",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-14607",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-14607",
"summary": "A vulnerability was detected in OFFIS DCMTK up to 3.6.9. Affected by this issue is the function DcmByteString::makeDicomByteString of the file dcmdata/libsrc/dcbytstr.cc of the component dcmdata. The manipulation results in memory corruption. The attack can be launched remotely. Upgrading to version 3.7.0 can resolve this issue. The patch is identified as 4c0e5c10079392c594d6a7abd95dd78ac0aa556a. You should upgrade the affected component.",
"evidence": "osv:DEBIAN-CVE-2025-14607",
"products": [
{
"name": {
"value": "dcmtk",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.6.7-9~deb12u4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "3.6.7-8",
"evidence": "/affected/0/versions"
},
{
"value": "3.6.7-9~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "3.6.7-9~deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "3.6.7-9~deb12u3",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "dcmtk",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.6.9-5+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "3.6.9-5",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "dcmtk",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.7.0+really3.7.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "3.6.9-5",
"evidence": "/affected/2/versions"
},
{
"value": "3.6.9-6",
"evidence": "/affected/2/versions"
},
{
"value": "3.7.0+really3.6.9-1",
"evidence": "/affected/2/versions"
},
{
"value": "3.7.0+really3.7.0-0+exp1",
"evidence": "/affected/2/versions"
},
{
"value": "3.7.0-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2025-14607",
"aliases": [
"DEBIAN-CVE-2025-14607"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.6.7-9~deb12u4"
}
]
}
],
"package": {
"name": "dcmtk",
"purl": "pkg:deb/debian/dcmtk?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.6.7-8",
"3.6.7-9~deb12u1",
"3.6.7-9~deb12u2",
"3.6.7-9~deb12u3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-14607.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.6.9-5+deb13u1"
}
]
}
],
"package": {
"name": "dcmtk",
"purl": "pkg:deb/debian/dcmtk?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"3.6.9-5"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-14607.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.7.0+really3.7.0-1"
}
]
}
],
"package": {
"name": "dcmtk",
"purl": "pkg:deb/debian/dcmtk?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"3.6.9-5",
"3.6.9-6",
"3.7.0+really3.6.9-1",
"3.7.0+really3.7.0-0+exp1",
"3.7.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-14607.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-08T09:47:30.484213333Z",
"provider": "osv",
"upstream": [
"CVE-2025-14607"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-14607"
]
},
"related_cves": [
{
"value": "CVE-2025-14607",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98882,
"published_at": "2025-12-13T16:16:52.84+00:00"
}