Skip to content
Heist/ feed
Back to feed
Medium

WordPress Cooked Plugin - Cross-Site Request Forgery to Default Recipe Template Save

Type: advisorySources: OSV

Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Cross-Site Request Forgery (CSRF) in versions up to, and including, 1.7.15.4 due to missing or incorrect nonce validation on the AJAX action handler. This vulnerability could allow an attacker to trick users into performing an action they didn't intend to perform under their current authentication. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-39680
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 03:13 UTC · Revision 1

Source evidence

WordPress Cooked Plugin - Cross-Site Request Forgery to Default Recipe Template Save

core-osv · Original source

Published 17 Jul 2024, 23:47 UTC

Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Cross-Site Request Forgery (CSRF) in versions up to, and including, 1.7.15.4 due to missing or incorrect nonce validation on the AJAX action handler. This vulnerability could allow an attacker to trick users into performing an action they didn't intend to perform under their current authentication. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

osv:CVE-2024-39680
Complete source record
{
  "id": "3d2eed561c993eba34f9be813932468de937c745825d8008e2f24661600d2702",
  "url": "https://osv.dev/vulnerability/CVE-2024-39680",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WordPress Cooked Plugin - Cross-Site Request Forgery to Default Recipe Template Save",
    "summary": "Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Cross-Site Request Forgery (CSRF) in versions up to, and including, 1.7.15.4 due to missing or incorrect nonce validation on the AJAX action handler. This vulnerability could allow an attacker to trick users into performing an action they didn't intend to perform under their current authentication. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.",
    "evidence": "osv:CVE-2024-39680",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-39680",
      "aliases": [
        "CVE-2024-39680",
        "GHSA-f2mc-hcp9-6xgr"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/xjsv/cooked",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "b1d5b5bd17a56534118c1c2609b1b88d13233cf5"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.8.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:boxystudio:cooked:*:*:*:*:pro:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.8.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.7.15.4",
            "v1.7.15.3",
            "v1.7.15.2",
            "v1.7.14"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-39680.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:33.014823685Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/39xxx/CVE-2024-39680.json",
        "https://github.com/XjSv/Cooked/security/advisories/GHSA-f2mc-hcp9-6xgr",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-39680"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-352"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/39xxx/CVE-2024-39680.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-39680",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 499948,
  "published_at": "2024-07-17T23:47:52.745+00:00"
}