pyopenssl — security advisory
Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.
- Products
- pyopenssl
- Affected versions
- Not specified
- Fixed versions
- 17.5.0-1
- CVEs
- CVE-2018-1000808
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:25 UTC · Revision 1
Source evidence
Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.
osv:DEBIAN-CVE-2018-1000808
pyopenssl
Fixed versions: 17.5.0-1
pyopenssl
Fixed versions: 17.5.0-1
pyopenssl
Fixed versions: 17.5.0-1
Complete source record
{
"id": "c78bfac1822be81d8303f2147fe70c608701a8c3eee5a4cdc898e2d2b3eda037",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000808",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-1000808",
"summary": "Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.",
"evidence": "osv:DEBIAN-CVE-2018-1000808",
"products": [
{
"name": {
"value": "pyopenssl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "17.5.0-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pyopenssl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "17.5.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pyopenssl",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "17.5.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2018-1000808",
"aliases": [
"DEBIAN-CVE-2018-1000808"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.5.0-1"
}
]
}
],
"package": {
"name": "pyopenssl",
"purl": "pkg:deb/debian/pyopenssl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000808.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.5.0-1"
}
]
}
],
"package": {
"name": "pyopenssl",
"purl": "pkg:deb/debian/pyopenssl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000808.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.5.0-1"
}
]
}
],
"package": {
"name": "pyopenssl",
"purl": "pkg:deb/debian/pyopenssl?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000808.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-23T18:03:17.988063758Z",
"provider": "osv",
"upstream": [
"CVE-2018-1000808"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-1000808"
]
},
"related_cves": [
{
"value": "CVE-2018-1000808",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 421053,
"published_at": "2018-10-08T15:29:00.947+00:00"
}