Skip to content
Heist/ feed
Back to feed
Medium

Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters

Type: advisorySources: OSV

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][metadata], data[header][taxonomy][category], and data[header][taxonomy][tag] parameters. These scripts are stored in the page frontmatter and executed automatically whenever the affected page is accessed or rendered in the administrative interface. This vulnerability is fixed in 1.11.0-beta.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-66311
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 02:28 UTC · Revision 1

Source evidence

Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters

core-osv · Original source

Published 1 Dec 2025, 22:05 UTC

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][metadata], data[header][taxonomy][category], and data[header][taxonomy][tag] parameters. These scripts are stored in the page frontmatter and executed automatically whenever the affected page is accessed or rendered in the administrative interface. This vulnerability is fixed in 1.11.0-beta.1.

osv:CVE-2025-66311
Complete source record
{
  "id": "14cbab145b023a4e91bfddd839d0fb2b9f06fd6920223c02b3ed9b00cd333072",
  "url": "https://osv.dev/vulnerability/CVE-2025-66311",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters",
    "summary": "This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][metadata], data[header][taxonomy][category], and data[header][taxonomy][tag] parameters. These scripts are stored in the page frontmatter and executed automatically whenever the affected page is accessed or rendered in the administrative interface. This vulnerability is fixed in 1.11.0-beta.1.",
    "evidence": "osv:CVE-2025-66311",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-66311",
      "aliases": [
        "CVE-2025-66311",
        "GHSA-mpjj-4688-3fxg"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/getgrav/grav-plugin-admin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "99f653296504f1d6408510dd2f6f20a45a26f9b0"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:getgrav:grav-plugin-admin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "1.10.50"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "99f653296504f1d6408510dd2f6f20a45a26f9b0"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.10.0-rc.20",
            "1.10.0-rc.19",
            "1.10.0-rc.18",
            "1.10.0-rc.17",
            "1.10.0-rc.16",
            "1.10.0-rc.15",
            "1.10.0-rc.14",
            "1.10.0-rc.13",
            "1.10.0-rc.12",
            "1.10.0-rc.11",
            "1.10.0-rc.10",
            "1.10.0-rc.9",
            "1.10.0-rc.8",
            "1.10.0-rc.7",
            "1.10.0-rc.6",
            "1.10.0-rc.5",
            "1.10.0-rc.4",
            "1.10.0-rc.3",
            "1.10.0-rc.2",
            "1.10.0-rc.1",
            "1.10.0-beta.10",
            "1.10.0-beta.9",
            "1.10.0-beta.8",
            "1.10.0-beta.7",
            "1.10.0-beta.6",
            "1.10.0-beta.5",
            "1.10.0-beta.4",
            "1.10.0-beta.3",
            "1.10.0-beta.2",
            "1.10.0-beta.1",
            "1.7.1",
            "1.7.0",
            "1.6.7",
            "1.6.6",
            "1.6.5",
            "1.6.4",
            "1.6.3",
            "1.6.2",
            "1.6.1",
            "1.6.0",
            "1.5.2",
            "1.5.1",
            "1.5.0",
            "1.4.2",
            "1.4.1",
            "1.4.0",
            "1.3.3",
            "1.3.2",
            "1.3.1",
            "1.3.0",
            "1.2.14",
            "1.2.13",
            "1.2.12",
            "1.2.5-rc.4",
            "1.2.5-rc.3",
            "1.2.5-rc.2",
            "1.2.5-rc.1",
            "1.2.0-rc.2",
            "1.2.0-rc.1",
            "1.1.0-rc.4",
            "1.1.0-rc.3",
            "1.1.0-rc.2",
            "1.1.0-rc.1",
            "1.1.0-beta.5",
            "1.1.0-beta.4",
            "1.1.0-beta.3",
            "1.1.0-beta.2",
            "1.1.0-beta.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-66311.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:25.468187543Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66311.json",
        "https://github.com/getgrav/grav/security/advisories/GHSA-mpjj-4688-3fxg",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-66311",
        "https://github.com/getgrav/grav-plugin-admin/commit/99f653296504f1d6408510dd2f6f20a45a26f9b0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66311.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-66311",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 491812,
  "published_at": "2025-12-01T22:05:17.671+00:00"
}