Paid Memberships Pro <= 3.0.1 - Cross-Site Request Forgery
The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.1. This is due to missing or incorrect nonce validation on the pmpro_update_level_group_order() function. This makes it possible for unauthenticated attackers to update order levels via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-3215
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:33 UTC · Revision 1
Source evidence
Paid Memberships Pro <= 3.0.1 - Cross-Site Request Forgery
core-osv · Original sourcePublished 2 May 2024, 16:52 UTC
The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.1. This is due to missing or incorrect nonce validation on the pmpro_update_level_group_order() function. This makes it possible for unauthenticated attackers to update order levels via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
osv:CVE-2024-3215
Complete source record
{
"id": "4e384cb562067f68e12706662e540bbf586b3ec395fd6588c7e168d73cef3d5d",
"url": "https://osv.dev/vulnerability/CVE-2024-3215",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Paid Memberships Pro <= 3.0.1 - Cross-Site Request Forgery",
"summary": "The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.1. This is due to missing or incorrect nonce validation on the pmpro_update_level_group_order() function. This makes it possible for unauthenticated attackers to update order levels via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.",
"evidence": "osv:CVE-2024-3215",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-3215",
"aliases": [
"CVE-2024-3215"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/strangerstudios/paid-memberships-pro",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "661bf5f5f8590b2f4f298cd832151125a692b55d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:strangerstudios:paid_memberships_pro:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.0.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.0.1",
"3.0",
"3.0-rc.4",
"3.0-rc.3",
"3.0-rc.2",
"3.0-rc.1",
"v2.5.2",
"2.9.2",
"2.9.3",
"2.9.1",
"2.8.3",
"2.8.2",
"2.8.1",
"2.8",
"2.7.4",
"2.7.5",
"2.7.3",
"2.7.2",
"2.7.1",
"2.7",
"v2.4.4",
"2.6.6",
"2.6.5",
"2.6.4",
"2.6.3",
"2.6.2",
"2.6.1.1",
"2.6.1",
"2.6",
"v2.5.7",
"v2.5.6",
"v2.5.5",
"v2.5.4",
"v2.5.1",
"v2.5",
"v2.0.5",
"v2.4.3",
"v2.4.2",
"v2.4.1",
"v2.4",
"v2.3.4",
"v2.3.3",
"v2.2.6",
"v2.2.5",
"v2.2.3",
"v2.2.4",
"v2.2.2",
"v2.2",
"v2.0.7",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0",
"release-1.9.4.4",
"release-1.9.4.2",
"release-1.9.4.3",
"release-1.9.4.1",
"release-1.9.4",
"archive/v1.9.4",
"release-1.9.3",
"release-1.9.2.1",
"release-1.9.2",
"release-1.9.1",
"release-1.9",
"release-1.8.13.6",
"release-1.8.13.5",
"release-1.8.13.4",
"release-1.8.13.3",
"release-1.8.13.2",
"release-1.8.13.1",
"release-1.8.13",
"release-1.8.12.1",
"release-1.8.12",
"release-1.8.11.2",
"release-1.8.11.1",
"release-1.8.11",
"release-1.8.10.4",
"release-1.8.10.3",
"release-1.8.10.2",
"release-1.8.10.1",
"release-1.8.9.1",
"release-1.8.9",
"release-1.8.8.3",
"release-1.8.8.1",
"release-1.8.8",
"release-1.8.7.3",
"release-1.8.7",
"release-1.8.6.8",
"release-1.8.6.7",
"release-1.8.6.6",
"release-1.8.4.5",
"release-1.8.4.3",
"release-1.8.4.2",
"release-1.8.4",
"release-1.8.3",
"release-1.8.2.2",
"release-v1.8.2.1",
"release-1.8.2",
"release-1.8.1",
"release-1.8",
"v1.7.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-3215.json"
}
}
],
"modified": "2026-10-28T02:30:25.028074146Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset/3069136/paid-memberships-pro/trunk/includes/services.php",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/a9ef7742-e6f8-4350-90e9-242d9d1b12a0?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/3xxx/CVE-2024-3215.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-3215"
],
"provider_metadata": {
"cwe_ids": [
"CWE-352"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "3.0.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/3xxx/CVE-2024-3215.json"
}
},
"related_cves": [
{
"value": "CVE-2024-3215",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491661,
"published_at": "2024-05-02T16:52:29.758+00:00"
}