omec-project amf handler.go NGSetupRequest memory corruption
A vulnerability was determined in omec-project amf up to 2.1.3-dev. Impacted is the function NGSetupRequest of the file ngap/handler.go. Executing a manipulation of the argument InformationElement can lead to memory corruption. The attack can be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.2.0 is recommended to address this issue. The affected component should be upgraded. The same pull request fixes multiple security issues.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-8779
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 06:06 UTC · Revision 1
Source evidence
omec-project amf handler.go NGSetupRequest memory corruption
core-osv · Original sourcePublished 18 May 2026, 01:15 UTC
A vulnerability was determined in omec-project amf up to 2.1.3-dev. Impacted is the function NGSetupRequest of the file ngap/handler.go. Executing a manipulation of the argument InformationElement can lead to memory corruption. The attack can be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.2.0 is recommended to address this issue. The affected component should be upgraded. The same pull request fixes multiple security issues.
osv:CVE-2026-8779
Complete source record
{
"id": "3d45966c973b101a13126d8437ee8b113c245b71182ee96f85065edbb6d57acf",
"url": "https://osv.dev/vulnerability/CVE-2026-8779",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "omec-project amf handler.go NGSetupRequest memory corruption",
"summary": "A vulnerability was determined in omec-project amf up to 2.1.3-dev. Impacted is the function NGSetupRequest of the file ngap/handler.go. Executing a manipulation of the argument InformationElement can lead to memory corruption. The attack can be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.2.0 is recommended to address this issue. The affected component should be upgraded. The same pull request fixes multiple security issues.",
"evidence": "osv:CVE-2026-8779",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2026-8779",
"aliases": [
"CVE-2026-8779",
"GHSA-fxvj-wqv2-xgcq",
"GO-2026-5386"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/omec-project/amf",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "34bc6724acc97dba1f8691e586da95b042cb612d"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"fixed": "34bc6724acc97dba1f8691e586da95b042cb612d"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v2.2.0"
}
]
}
}
],
"versions": [
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.7.0",
"v1.6.7",
"v1.6.6",
"v1.6.5",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.5.1",
"v1.5.0",
"v1.4.5",
"v1.4.4",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.0",
"v1.2.0",
"v1.1.1",
"v1.1.0",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-8779.json"
}
}
],
"modified": "2026-10-28T02:30:43.011880604Z",
"provider": "osv",
"references": [
"https://github.com/omec-project/amf/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/8xxx/CVE-2026-8779.json",
"https://nvd.nist.gov/vuln/detail/CVE-2026-8779",
"https://vuldb.com/submit/811616",
"https://vuldb.com/vuln/364403",
"https://github.com/omec-project/amf/issues/671",
"https://vuldb.com/vuln/364403/cti",
"https://github.com/omec-project/amf/pull/666",
"https://github.com/omec-project/amf/releases/tag/v2.2.0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-119"
],
"cna_assigner": "VulDB",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.1.3-dev"
},
{
"last_affected": "2.1.3-dev"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
},
{
"extracted_events": [
{
"range": [
{
"last_affected": "2.1.3-dev"
}
],
"source": "DESCRIPTION"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/8xxx/CVE-2026-8779.json"
}
},
"related_cves": [
{
"value": "CVE-2026-8779",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 510955,
"published_at": "2026-05-18T01:15:12.132+00:00"
}