High
Fides: DOM-based XSS vulnerability in fides.js via fides_description override
Type: advisorySources: OSV
Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-44541
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 14:09 UTC · Revision 1
Source evidence
Fides: DOM-based XSS vulnerability in fides.js via fides_description override
core-osv · Original sourcePublished 8 Jun 2026, 20:01 UTC
Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.
osv:CVE-2026-44541
Complete source record
{
"id": "52f732f52119bd5019214b9ca91a4cba353939fc3b581a8e310873b18bb09b5c",
"url": "https://osv.dev/vulnerability/CVE-2026-44541",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Fides: DOM-based XSS vulnerability in fides.js via fides_description override",
"summary": "Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.",
"evidence": "osv:CVE-2026-44541",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-44541",
"aliases": [
"CVE-2026-44541",
"GHSA-5qrq-9645-g5g2",
"PYSEC-2026-2470"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ethyca/fides",
"type": "GIT",
"events": [
{
"introduced": "d0c2893d6f00932504e8da16bce776d5cb17492a"
},
{
"fixed": "67e43b10b1096c7f84d5c0eeba08ee3b7846b7cd"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.33.0"
},
{
"fixed": "2.84.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "67e43b10b1096c7f84d5c0eeba08ee3b7846b7cd"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "67e43b10b1096c7f84d5c0eeba08ee3b7846b7cd"
}
],
"source": "REFERENCES_TAG",
"original_tag": "2.84.5"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.84.5"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-44541.json"
}
}
],
"modified": "2026-10-28T02:30:29.218174664Z",
"provider": "osv",
"references": [
"https://github.com/ethyca/fides/releases/tag/2.84.5",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44541.json",
"https://github.com/ethyca/fides/security/advisories/GHSA-5qrq-9645-g5g2",
"https://nvd.nist.gov/vuln/detail/CVE-2026-44541",
"https://github.com/ethyca/fides/commit/67e43b10b1096c7f84d5c0eeba08ee3b7846b7cd"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44541.json"
}
},
"related_cves": [
{
"value": "CVE-2026-44541",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496234,
"published_at": "2026-06-08T20:01:54.675+00:00"
}