HighFix available
Ghost 2.21.0 before 6.56.0 Privilege Escalation via Notifications
Type: advisorySources: OSV
Ghost versions from 2.21.0 before 6.56.0 contain a privilege escalation vulnerability in the notifications system that allows low-privilege staff users to escalate to higher-privilege staff roles. Attackers with low-privilege staff access can exploit the notifications system to gain elevated privileges without proper authorization checks.
- Products
- ghost
- Affected versions
- Not specified
- Fixed versions
- 6.56.0
- CVEs
- CVE-2026-103286
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 12:32 UTC · Revision 1
Source evidence
Ghost 2.21.0 before 6.56.0 Privilege Escalation via Notifications
core-osv · Original sourcePublished 9 Oct 2026, 10:45 UTC
Ghost versions from 2.21.0 before 6.56.0 contain a privilege escalation vulnerability in the notifications system that allows low-privilege staff users to escalate to higher-privilege staff roles. Attackers with low-privilege staff access can exploit the notifications system to gain elevated privileges without proper authorization checks.
osv:BIT-ghost-2026-103286
ghost
Fixed versions: 6.56.0
Complete source record
{
"id": "0b93dce5932506bbe0a8557f602f83246039a38ec261d8a9411915a599456a7c",
"url": "https://osv.dev/vulnerability/BIT-ghost-2026-103286",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Ghost 2.21.0 before 6.56.0 Privilege Escalation via Notifications",
"summary": "Ghost versions from 2.21.0 before 6.56.0 contain a privilege escalation vulnerability in the notifications system that allows low-privilege staff users to escalate to higher-privilege staff roles. Attackers with low-privilege staff access can exploit the notifications system to gain elevated privileges without proper authorization checks.",
"evidence": "osv:BIT-ghost-2026-103286",
"products": [
{
"name": {
"value": "ghost",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.56.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "BIT-ghost-2026-103286",
"aliases": [
"BIT-ghost-2026-103286",
"CVE-2026-103286",
"GHSA-pv24-pfvg-vr83"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "2.21.0"
},
{
"fixed": "6.56.0"
}
]
}
],
"package": {
"name": "ghost",
"purl": "pkg:bitnami/ghost",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/ghost/BIT-ghost-2026-103286.json"
}
}
],
"modified": "2026-10-09T12:10:29.616733260Z",
"provider": "osv",
"references": [
"https://github.com/TryGhost/Ghost/security/advisories/GHSA-pv24-pfvg-vr83",
"https://nvd.nist.gov/vuln/detail/CVE-2026-103286",
"https://www.vulncheck.com/advisories/ghost-2.21.0-before-6.56.0-privilege-escalation-via-notifications"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:ghost:ghost:*:*:*:*:*:node.js:*:*"
],
"severity": "High"
}
},
"related_cves": [
{
"value": "CVE-2026-103286",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 120731,
"published_at": "2026-10-09T10:45:05.579+00:00"
}