phpmyadmin — security advisory
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted database name, related to the Database Synchronize panel; (2) a crafted database name, related to the Database rename panel; (3) a crafted SQL query, related to the table overview panel; (4) a crafted SQL query, related to the view creation dialog; (5) a crafted column type, related to the table search dialog; or (6) a crafted column type, related to the create index dialog.
- Products
- phpmyadmin
- Affected versions
- Not specified
- Fixed versions
- 4:3.4.8-1
- CVEs
- CVE-2011-4634
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 23:29 UTC · Revision 1
Source evidence
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted database name, related to the Database Synchronize panel; (2) a crafted database name, related to the Database rename panel; (3) a crafted SQL query, related to the table overview panel; (4) a crafted SQL query, related to the view creation dialog; (5) a crafted column type, related to the table search dialog; or (6) a crafted column type, related to the create index dialog.
osv:DEBIAN-CVE-2011-4634
phpmyadmin
Fixed versions: 4:3.4.8-1
phpmyadmin
Fixed versions: 4:3.4.8-1
phpmyadmin
Fixed versions: 4:3.4.8-1
Complete source record
{
"id": "036ff993a42b7f0f2e35473ffd49a0c01848903c568a95bfda6ed81de8d30ac5",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-4634",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2011-4634",
"summary": "Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted database name, related to the Database Synchronize panel; (2) a crafted database name, related to the Database rename panel; (3) a crafted SQL query, related to the table overview panel; (4) a crafted SQL query, related to the view creation dialog; (5) a crafted column type, related to the table search dialog; or (6) a crafted column type, related to the create index dialog.",
"evidence": "osv:DEBIAN-CVE-2011-4634",
"products": [
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.4.8-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.4.8-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.4.8-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2011-4634",
"aliases": [
"DEBIAN-CVE-2011-4634"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.4.8-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-4634.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.4.8-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-4634.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.4.8-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-4634.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-23T17:47:45.369233528Z",
"provider": "osv",
"upstream": [
"CVE-2011-4634"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2011-4634"
]
},
"related_cves": [
{
"value": "CVE-2011-4634",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 418742,
"published_at": "2011-12-22T20:55:00.937+00:00"
}