guake — security advisory
The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.
- Products
- guake
- Affected versions
- Not specified
- Fixed versions
- 3.8.5-1
- CVEs
- CVE-2021-23556
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:20 UTC · Revision 1
Source evidence
The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.
osv:DEBIAN-CVE-2021-23556
guake
Fixed versions: 3.8.5-1
guake
Fixed versions: 3.8.5-1
guake
Fixed versions: 3.8.5-1
Complete source record
{
"id": "9faaf289097e05dfa13f92ae39fa6570b752848f462f1d617d1b762574d88682",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-23556",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-23556",
"summary": "The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.",
"evidence": "osv:DEBIAN-CVE-2021-23556",
"products": [
{
"name": {
"value": "guake",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8.5-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "guake",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8.5-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "guake",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8.5-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2021-23556",
"aliases": [
"DEBIAN-CVE-2021-23556"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8.5-1"
}
]
}
],
"package": {
"name": "guake",
"purl": "pkg:deb/debian/guake?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23556.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8.5-1"
}
]
}
],
"package": {
"name": "guake",
"purl": "pkg:deb/debian/guake?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23556.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8.5-1"
}
]
}
],
"package": {
"name": "guake",
"purl": "pkg:deb/debian/guake?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23556.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:12.073826289Z",
"provider": "osv",
"upstream": [
"CVE-2021-23556"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-23556"
]
},
"related_cves": [
{
"value": "CVE-2021-23556",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420792,
"published_at": "2022-03-17T12:15:07.59+00:00"
}