c-blosc2 — security advisory
A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.
- Products
- c-blosc2
- Affected versions
- 2.12.0+ds-1, 2.12.0+ds-2, 2.13.1+ds-1, 2.13.1+ds-1.1ubuntu1, 2.13.1+ds-1.1ubuntu2, 2.13.1+ds-1ubuntu1, 2.16.0+ds-1, 2.17.1+ds-1, 2.17.1+ds-2, 2.22.0+ds-1, 2.23.0+ds-1, 2.23.1+ds-1, 2.23.1+ds-2
- Fixed versions
- Not specified
- CVEs
- CVE-2024-3203
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 01:07 UTC · Revision 1
Source evidence
A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.
osv:UBUNTU-CVE-2024-3203
c-blosc2
Fixed versions: Not specified
c-blosc2
Fixed versions: Not specified
c-blosc2
Fixed versions: Not specified
c-blosc2
Fixed versions: Not specified
Complete source record
{
"id": "103d350fc3268db43508227a56cddeb9eb557cc4902177efabb99d292a8ea871",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2024-3203",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2024-3203",
"summary": "A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.",
"evidence": "osv:UBUNTU-CVE-2024-3203",
"products": [
{
"name": {
"value": "c-blosc2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.12.0+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.12.0+ds-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.13.1+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.13.1+ds-1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "2.13.1+ds-1.1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "2.13.1+ds-1.1ubuntu2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "c-blosc2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.16.0+ds-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.17.1+ds-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.17.1+ds-2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "c-blosc2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.23.0+ds-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.23.1+ds-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.23.1+ds-2",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "c-blosc2",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.17.1+ds-2",
"evidence": "/affected/3/versions"
},
{
"value": "2.22.0+ds-1",
"evidence": "/affected/3/versions"
},
{
"value": "2.23.0+ds-1",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "critical",
"structured": {
"id": "UBUNTU-CVE-2024-3203",
"aliases": [
"UBUNTU-CVE-2024-3203"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "c-blosc2",
"purl": "pkg:deb/ubuntu/c-blosc2?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"2.12.0+ds-1",
"2.12.0+ds-2",
"2.13.1+ds-1",
"2.13.1+ds-1ubuntu1",
"2.13.1+ds-1.1ubuntu1",
"2.13.1+ds-1.1ubuntu2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2024/UBUNTU-CVE-2024-3203.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libblosc2-2t64",
"binary_version": "2.13.1+ds-1.1ubuntu2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "c-blosc2",
"purl": "pkg:deb/ubuntu/c-blosc2?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"2.16.0+ds-1",
"2.17.1+ds-1",
"2.17.1+ds-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2024/UBUNTU-CVE-2024-3203.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libblosc2-4",
"binary_version": "2.17.1+ds-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "c-blosc2",
"purl": "pkg:deb/ubuntu/c-blosc2?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"2.23.0+ds-1",
"2.23.1+ds-1",
"2.23.1+ds-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2024/UBUNTU-CVE-2024-3203.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libblosc2-7",
"binary_version": "2.23.1+ds-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "c-blosc2",
"purl": "pkg:deb/ubuntu/c-blosc2?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"2.17.1+ds-2",
"2.22.0+ds-1",
"2.23.0+ds-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2024/UBUNTU-CVE-2024-3203.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libblosc2-7",
"binary_version": "2.23.0+ds-1"
}
]
}
}
],
"modified": "2026-10-17T12:56:35.403099703Z",
"provider": "osv",
"upstream": [
"CVE-2024-3203"
],
"references": [
"https://ubuntu.com/security/CVE-2024-3203",
"https://vuldb.com/?id.259050",
"https://vuldb.com/?ctiid.259050",
"https://vuldb.com/?submit.304556",
"https://drive.google.com/drive/folders/1T1k3UeS09m65LjVXExUuZfedNQPWQWCo?usp=sharing",
"https://www.cve.org/CVERecord?id=CVE-2024-3203"
]
},
"related_cves": [
{
"value": "CVE-2024-3203",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 355824,
"published_at": "2024-04-02T22:15:00+00:00"
}