atril — security advisory
Atril Document Viewer is the default document reader of the MATE desktop environment for Linux. A path traversal and arbitrary file write vulnerability exists in versions of Atril prior to 1.26.2. This vulnerability is capable of writing arbitrary files anywhere on the filesystem to which the user opening a crafted document has access. The only limitation is that this vulnerability cannot be exploited to overwrite existing files, but that doesn't stop an attacker from achieving Remote Command Execution on the target system. Version 1.26.2 of Atril contains a patch for this vulnerability.
- Products
- atril
- Affected versions
- 1.26.0-2, 1.26.0-2+deb12u1, 1.26.0-2+deb12u2
- Fixed versions
- 1.26.0-2+deb12u3, 1.26.2-1
- CVEs
- CVE-2023-52076
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:00 UTC · Revision 1
Source evidence
Atril Document Viewer is the default document reader of the MATE desktop environment for Linux. A path traversal and arbitrary file write vulnerability exists in versions of Atril prior to 1.26.2. This vulnerability is capable of writing arbitrary files anywhere on the filesystem to which the user opening a crafted document has access. The only limitation is that this vulnerability cannot be exploited to overwrite existing files, but that doesn't stop an attacker from achieving Remote Command Execution on the target system. Version 1.26.2 of Atril contains a patch for this vulnerability.
osv:DEBIAN-CVE-2023-52076
atril
Fixed versions: 1.26.0-2+deb12u3
atril
Fixed versions: 1.26.2-1
atril
Fixed versions: 1.26.2-1
Complete source record
{
"id": "cf7ab8ef589558c6759b40e245ddb298894128ecd74bfd4ec1f66b8925d21d9e",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-52076",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-52076",
"summary": "Atril Document Viewer is the default document reader of the MATE desktop environment for Linux. A path traversal and arbitrary file write vulnerability exists in versions of Atril prior to 1.26.2. This vulnerability is capable of writing arbitrary files anywhere on the filesystem to which the user opening a crafted document has access. The only limitation is that this vulnerability cannot be exploited to overwrite existing files, but that doesn't stop an attacker from achieving Remote Command Execution on the target system. Version 1.26.2 of Atril contains a patch for this vulnerability.",
"evidence": "osv:DEBIAN-CVE-2023-52076",
"products": [
{
"name": {
"value": "atril",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.26.0-2+deb12u3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.26.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.26.0-2+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "1.26.0-2+deb12u2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "atril",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.26.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "atril",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.26.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-52076",
"aliases": [
"DEBIAN-CVE-2023-52076"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.26.0-2+deb12u3"
}
]
}
],
"package": {
"name": "atril",
"purl": "pkg:deb/debian/atril?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.26.0-2",
"1.26.0-2+deb12u1",
"1.26.0-2+deb12u2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-52076.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.26.2-1"
}
]
}
],
"package": {
"name": "atril",
"purl": "pkg:deb/debian/atril?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-52076.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.26.2-1"
}
]
}
],
"package": {
"name": "atril",
"purl": "pkg:deb/debian/atril?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-52076.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:36.425997391Z",
"provider": "osv",
"upstream": [
"CVE-2023-52076"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-52076"
]
},
"related_cves": [
{
"value": "CVE-2023-52076",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456368,
"published_at": "2024-01-25T16:15:07.93+00:00"
}