Skip to content
Heist/ feed
Back to feed
CriticalFix available

rails — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-32224

A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record < 7.0.3.1, <6.1.6.1, <6.0.5.1 and <5.2.8.1 which could allow an attacker, that can manipulate data in the database (via means like SQL injection), the ability to escalate to an RCE.

Products
rails
Affected versions
Not specified
Fixed versions
2:6.1.6.1+dfsg-1
CVEs
CVE-2022-32224
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:45 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-32224

core-osv · Original source

Published 5 Dec 2022, 22:15 UTC

A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record < 7.0.3.1, <6.1.6.1, <6.0.5.1 and <5.2.8.1 which could allow an attacker, that can manipulate data in the database (via means like SQL injection), the ability to escalate to an RCE.

osv:DEBIAN-CVE-2022-32224

rails

Fixed versions: 2:6.1.6.1+dfsg-1

rails

Fixed versions: 2:6.1.6.1+dfsg-1

rails

Fixed versions: 2:6.1.6.1+dfsg-1

Complete source record
{
  "id": "7517947d40102b7e0bd65c0fffad6cd2ebe14dba9ac77ce9871fec9eb7d9102f",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-32224",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-32224",
    "summary": "A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record < 7.0.3.1, <6.1.6.1, <6.0.5.1 and <5.2.8.1 which could allow an attacker, that can manipulate data in the database (via means like SQL injection), the ability to escalate to an RCE.",
    "evidence": "osv:DEBIAN-CVE-2022-32224",
    "products": [
      {
        "name": {
          "value": "rails",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2:6.1.6.1+dfsg-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "rails",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2:6.1.6.1+dfsg-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "rails",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2:6.1.6.1+dfsg-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2022-32224",
      "aliases": [
        "DEBIAN-CVE-2022-32224"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2:6.1.6.1+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "rails",
            "purl": "pkg:deb/debian/rails?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-32224.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2:6.1.6.1+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "rails",
            "purl": "pkg:deb/debian/rails?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-32224.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2:6.1.6.1+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "rails",
            "purl": "pkg:deb/debian/rails?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-32224.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:02:00.491593903Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-32224"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-32224"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-32224",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323231,
  "published_at": "2022-12-05T22:15:10.397+00:00"
}