Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2017-1000480

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2017-1000480
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 09:40 UTC · Revision 1

Source evidence

CVE-2017-1000480

core-osv · Original source

Published 3 Jan 2018, 18:29 UTC

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

osv:CVE-2017-1000480
Complete source record
{
  "id": "a62cd3a6aa11b82a6aa36b1be1bd36601ecfe0db3b07faf6b51c9e358fabc682",
  "url": "https://osv.dev/vulnerability/CVE-2017-1000480",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2017-1000480",
    "summary": "Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.",
    "evidence": "osv:CVE-2017-1000480",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2017-1000480",
      "aliases": [
        "CVE-2017-1000480",
        "GHSA-9m49-vhwv-422g"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/smarty-php/smarty",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "ac9d4b587e5bf53381e21881820a9830765cb459"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "3.0.0"
                      },
                      {
                        "fixed": "3.1.32"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v3.1.31",
            "v3.1.30",
            "v3.1.29",
            "v3.1.28",
            "v2.6.28",
            "v3.1.27",
            "v3.1.26",
            "v3.1.25",
            "v3.1.24",
            "v3.1.23",
            "v3.1.21",
            "v3.1.20",
            "v3.1.19",
            "v3.1.18",
            "v3.1.17",
            "v3.1.16",
            "v3.1.15",
            "v3.1.14",
            "v3.1.13",
            "v3.1.12",
            "v3.1.11",
            "v2.6.27",
            "v2.6.26",
            "v2.6.25",
            "v2.6.24"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-1000480.json"
          }
        }
      ],
      "modified": "2026-10-20T10:47:33.458829421Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2018/01/msg00023.html",
        "https://lists.debian.org/debian-lts-announce/2018/02/msg00000.html",
        "https://github.com/smarty-php/smarty/blob/master/change_log.txt",
        "https://www.debian.org/security/2018/dsa-4094"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2017-1000480",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 379502,
  "published_at": "2018-01-03T18:29:00.37+00:00"
}