libowasp-esapi-java — security advisory
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.
- Products
- libowasp-esapi-java
- Affected versions
- Not specified
- Fixed versions
- 2.4.0.0-1
- CVEs
- CVE-2022-23457
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:35 UTC · Revision 1
Source evidence
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.
osv:DEBIAN-CVE-2022-23457
libowasp-esapi-java
Fixed versions: 2.4.0.0-1
libowasp-esapi-java
Fixed versions: 2.4.0.0-1
Complete source record
{
"id": "5d93de224ae56c3053f6762c3ed16fa925d44dc9700a4d5cb6e211dca1f7653e",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23457",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-23457",
"summary": "ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.",
"evidence": "osv:DEBIAN-CVE-2022-23457",
"products": [
{
"name": {
"value": "libowasp-esapi-java",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.0.0-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libowasp-esapi-java",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.0.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2022-23457",
"aliases": [
"DEBIAN-CVE-2022-23457"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.0.0-1"
}
]
}
],
"package": {
"name": "libowasp-esapi-java",
"purl": "pkg:deb/debian/libowasp-esapi-java?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23457.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.0.0-1"
}
]
}
],
"package": {
"name": "libowasp-esapi-java",
"purl": "pkg:deb/debian/libowasp-esapi-java?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23457.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:00:46.980391281Z",
"provider": "osv",
"upstream": [
"CVE-2022-23457"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-23457"
]
},
"related_cves": [
{
"value": "CVE-2022-23457",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322645,
"published_at": "2022-04-25T20:15:41.87+00:00"
}