libowasp-esapi-java — security advisory
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the **antisamy-esapi.xml** configuration file that can cause "javascript:" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the **antisamy-esapi.xml** configuration files to change the "onsiteURL" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.
- Products
- libowasp-esapi-java
- Affected versions
- Not specified
- Fixed versions
- 2.4.0.0-1
- CVEs
- CVE-2022-24891
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:35 UTC · Revision 1
Source evidence
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the **antisamy-esapi.xml** configuration file that can cause "javascript:" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the **antisamy-esapi.xml** configuration files to change the "onsiteURL" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.
osv:DEBIAN-CVE-2022-24891
libowasp-esapi-java
Fixed versions: 2.4.0.0-1
libowasp-esapi-java
Fixed versions: 2.4.0.0-1
Complete source record
{
"id": "af27e8f15081579e835335ec70208c8754a8817e012fc87733ce02b2bd09426b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-24891",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-24891",
"summary": "ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for \"onsiteURL\" in the **antisamy-esapi.xml** configuration file that can cause \"javascript:\" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the **antisamy-esapi.xml** configuration files to change the \"onsiteURL\" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.",
"evidence": "osv:DEBIAN-CVE-2022-24891",
"products": [
{
"name": {
"value": "libowasp-esapi-java",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.0.0-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libowasp-esapi-java",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.0.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-24891",
"aliases": [
"DEBIAN-CVE-2022-24891"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.0.0-1"
}
]
}
],
"package": {
"name": "libowasp-esapi-java",
"purl": "pkg:deb/debian/libowasp-esapi-java?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24891.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.0.0-1"
}
]
}
],
"package": {
"name": "libowasp-esapi-java",
"purl": "pkg:deb/debian/libowasp-esapi-java?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24891.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:00:48.516541274Z",
"provider": "osv",
"upstream": [
"CVE-2022-24891"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-24891"
]
},
"related_cves": [
{
"value": "CVE-2022-24891",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322658,
"published_at": "2022-04-27T21:15:08.523+00:00"
}