Skip to content
Heist/ feed
Back to feed
High

GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

Type: advisorySources: OSV

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-58360
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 08:27 UTC · Revision 1

Source evidence

GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

core-osv · Original source

Published 25 Nov 2025, 20:17 UTC

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

osv:CVE-2025-58360
Complete source record
{
  "id": "db87ab30aa38224fe1976ede63179160eb2f9005ef344169b964dbd5531fe8d1",
  "url": "https://osv.dev/vulnerability/CVE-2025-58360",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature",
    "summary": "GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.",
    "evidence": "osv:CVE-2025-58360",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-58360",
      "aliases": [
        "CVE-2025-58360",
        "GHSA-fjf5-xgmq-5525"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/geoserver/geoserver",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "e42a91e7e8900ad1b40a4486be4c588e4f848124"
                },
                {
                  "introduced": "8f9b3e407de0b6a7d30fb9edf68ac6db0071b7bb"
                },
                {
                  "fixed": "dab1947ce0d1a46418ae690734be5ccc5252057b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.25.6"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.26.0"
                      },
                      {
                        "fixed": "2.26.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.21-M0",
            "2.11-beta"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-58360.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:33.804908626Z",
      "provider": "osv",
      "references": [
        "https://osgeo-org.atlassian.net/browse/GEOS-11682",
        "https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58360.json",
        "https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-58360"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-611"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58360.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-58360",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 501120,
  "published_at": "2025-11-25T20:17:35.254+00:00"
}