Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0
OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. JupyterHub < 5.0, when used with `GlobusOAuthenticator`, could be configured to allow all users from a particular institution only. This worked fine prior to JupyterHub 5.0, because `allow_all` did not take precedence over `identity_provider`. Since JupyterHub 5.0, `allow_all` does take precedence over `identity_provider`. On a hub with the same config, now all users will be allowed to login, regardless of `identity_provider`. `identity_provider` will basically be ignored. This is a documented change in JupyterHub 5.0, but is likely to catch many users by surprise. OAuthenticator 16.3.1 fixes the issue with JupyterHub 5.0, and does not affect previous versions. As a workaround, do not upgrade to JupyterHub 5.0 when using `GlobusOAuthenticator` in the prior configuration.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-37300
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 01:14 UTC · Revision 1
Source evidence
Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0
core-osv · Original sourcePublished 12 Jun 2024, 15:20 UTC
OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. JupyterHub < 5.0, when used with `GlobusOAuthenticator`, could be configured to allow all users from a particular institution only. This worked fine prior to JupyterHub 5.0, because `allow_all` did not take precedence over `identity_provider`. Since JupyterHub 5.0, `allow_all` does take precedence over `identity_provider`. On a hub with the same config, now all users will be allowed to login, regardless of `identity_provider`. `identity_provider` will basically be ignored. This is a documented change in JupyterHub 5.0, but is likely to catch many users by surprise. OAuthenticator 16.3.1 fixes the issue with JupyterHub 5.0, and does not affect previous versions. As a workaround, do not upgrade to JupyterHub 5.0 when using `GlobusOAuthenticator` in the prior configuration.
osv:CVE-2024-37300
Complete source record
{
"id": "8b4ae4bcab8ac8680a9c689108ae4ec8009151c3a539e8668cbeda466ef62caf",
"url": "https://osv.dev/vulnerability/CVE-2024-37300",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0",
"summary": "OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. JupyterHub < 5.0, when used with `GlobusOAuthenticator`, could be configured to allow all users from a particular institution only. This worked fine prior to JupyterHub 5.0, because `allow_all` did not take precedence over `identity_provider`. Since JupyterHub 5.0, `allow_all` does take precedence over `identity_provider`. On a hub with the same config, now all users will be allowed to login, regardless of `identity_provider`. `identity_provider` will basically be ignored. This is a documented change in JupyterHub 5.0, but is likely to catch many users by surprise. OAuthenticator 16.3.1 fixes the issue with JupyterHub 5.0, and does not affect previous versions. As a workaround, do not upgrade to JupyterHub 5.0 when using `GlobusOAuthenticator` in the prior configuration.",
"evidence": "osv:CVE-2024-37300",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-37300",
"aliases": [
"CVE-2024-37300",
"GHSA-gprj-3p75-f996",
"PYSEC-2026-1711"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jupyterhub/oauthenticator",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "5407435a21927ac7e8ea3dcf39631f416840b31c"
},
{
"fixed": "d1aea05fa89f2beae15ab0fa0b0d071030f79654"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "16.3.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "d1aea05fa89f2beae15ab0fa0b0d071030f79654"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"16.3.0",
"16.2.1",
"16.2.0",
"16.1.1",
"16.1.0",
"16.0.7",
"16.0.6",
"16.0.5",
"16.0.4",
"16.0.3",
"16.0.2",
"16.0.1",
"16.0.0",
"15.1.0",
"15.0.1",
"15.0.0",
"14.2.0",
"14.1.0",
"14.0.0",
"0.13.0",
"0.12.3",
"0.12.1",
"0.12.0",
"0.11.0",
"0.10.0",
"0.8.2",
"0.8.1",
"0.8.0",
"0.6.1",
"0.7.2",
"0.7.1",
"0.7.0",
"0.6.0",
"0.5.1",
"0.5.0",
"0.4.1",
"0.4.0",
"0.3.0",
"0.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-37300.json"
}
}
],
"modified": "2026-10-28T02:30:41.545458974Z",
"provider": "osv",
"references": [
"https://jupyterhub.readthedocs.io/en/stable/howto/upgrading-v5.html#authenticator-allow-all-and-allow-existing-users",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/37xxx/CVE-2024-37300.json",
"https://github.com/jupyterhub/oauthenticator/security/advisories/GHSA-gprj-3p75-f996",
"https://nvd.nist.gov/vuln/detail/CVE-2024-37300",
"https://github.com/jupyterhub/oauthenticator/commit/d1aea05fa89f2beae15ab0fa0b0d071030f79654"
],
"provider_metadata": {
"cwe_ids": [
"CWE-863"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/37xxx/CVE-2024-37300.json"
}
},
"related_cves": [
{
"value": "CVE-2024-37300",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 508964,
"published_at": "2024-06-12T15:20:20.363+00:00"
}