MediumFix available
wordpress — security advisory
Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.
- Products
- wordpress
- Affected versions
- Not specified
- Fixed versions
- 4.9.5+dfsg1-1
- CVEs
- CVE-2018-10102
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:30 UTC · Revision 1
Source evidence
Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.
osv:DEBIAN-CVE-2018-10102
wordpress
Fixed versions: 4.9.5+dfsg1-1
wordpress
Fixed versions: 4.9.5+dfsg1-1
wordpress
Fixed versions: 4.9.5+dfsg1-1
Complete source record
{
"id": "ae1377f5313b7f42422d1eff5bd1c99355879eba98e8bbfd82a1f300ce850ee2",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-10102",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-10102",
"summary": "Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.",
"evidence": "osv:DEBIAN-CVE-2018-10102",
"products": [
{
"name": {
"value": "wordpress",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.9.5+dfsg1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wordpress",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.9.5+dfsg1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wordpress",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.9.5+dfsg1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2018-10102",
"aliases": [
"DEBIAN-CVE-2018-10102"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.9.5+dfsg1-1"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10102.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.9.5+dfsg1-1"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10102.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.9.5+dfsg1-1"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10102.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:22.889142039Z",
"provider": "osv",
"upstream": [
"CVE-2018-10102"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-10102"
]
},
"related_cves": [
{
"value": "CVE-2018-10102",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 421310,
"published_at": "2018-04-16T09:58:09.713+00:00"
}