Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a user enumeration and email disclosure vulnerability exists in Grav. The "Forgot Password" functionality at /admin/forgot leaks information about valid usernames and their associated email addresses through distinct server responses. This allows an attacker to enumerate users and disclose sensitive email addresses, which can be leveraged for targeted attacks such as password spraying, phishing, or social engineering. This vulnerability is fixed in 1.11.0-beta.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-66307
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 03:52 UTC · Revision 1
Source evidence
Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure
core-osv · Original sourcePublished 1 Dec 2025, 21:53 UTC
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a user enumeration and email disclosure vulnerability exists in Grav. The "Forgot Password" functionality at /admin/forgot leaks information about valid usernames and their associated email addresses through distinct server responses. This allows an attacker to enumerate users and disclose sensitive email addresses, which can be leveraged for targeted attacks such as password spraying, phishing, or social engineering. This vulnerability is fixed in 1.11.0-beta.1.
osv:CVE-2025-66307
Complete source record
{
"id": "df0807d9d3e8b4efc5b237587c2bd1adb3cfd219fc14111d4ad3af7ca651cbf6",
"url": "https://osv.dev/vulnerability/CVE-2025-66307",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure",
"summary": "This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a user enumeration and email disclosure vulnerability exists in Grav. The \"Forgot Password\" functionality at /admin/forgot leaks information about valid usernames and their associated email addresses through distinct server responses. This allows an attacker to enumerate users and disclose sensitive email addresses, which can be leveraged for targeted attacks such as password spraying, phishing, or social engineering. This vulnerability is fixed in 1.11.0-beta.1.",
"evidence": "osv:CVE-2025-66307",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-66307",
"aliases": [
"CVE-2025-66307",
"GHSA-q3qx-cp62-f6m7"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/getgrav/grav-plugin-admin",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "99f653296504f1d6408510dd2f6f20a45a26f9b0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:getgrav:grav-plugin-admin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "1.10.50"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "99f653296504f1d6408510dd2f6f20a45a26f9b0"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.10.0-rc.20",
"1.10.0-rc.19",
"1.10.0-rc.18",
"1.10.0-rc.17",
"1.10.0-rc.16",
"1.10.0-rc.15",
"1.10.0-rc.14",
"1.10.0-rc.13",
"1.10.0-rc.12",
"1.10.0-rc.11",
"1.10.0-rc.10",
"1.10.0-rc.9",
"1.10.0-rc.8",
"1.10.0-rc.7",
"1.10.0-rc.6",
"1.10.0-rc.5",
"1.10.0-rc.4",
"1.10.0-rc.3",
"1.10.0-rc.2",
"1.10.0-rc.1",
"1.10.0-beta.10",
"1.10.0-beta.9",
"1.10.0-beta.8",
"1.10.0-beta.7",
"1.10.0-beta.6",
"1.10.0-beta.5",
"1.10.0-beta.4",
"1.10.0-beta.3",
"1.10.0-beta.2",
"1.10.0-beta.1",
"1.7.1",
"1.7.0",
"1.6.7",
"1.6.6",
"1.6.5",
"1.6.4",
"1.6.3",
"1.6.2",
"1.6.1",
"1.6.0",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.2",
"1.4.1",
"1.4.0",
"1.3.3",
"1.3.2",
"1.3.1",
"1.3.0",
"1.2.14",
"1.2.13",
"1.2.12",
"1.2.5-rc.4",
"1.2.5-rc.3",
"1.2.5-rc.2",
"1.2.5-rc.1",
"1.2.0-rc.2",
"1.2.0-rc.1",
"1.1.0-rc.4",
"1.1.0-rc.3",
"1.1.0-rc.2",
"1.1.0-rc.1",
"1.1.0-beta.5",
"1.1.0-beta.4",
"1.1.0-beta.3",
"1.1.0-beta.2",
"1.1.0-beta.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-66307.json"
}
}
],
"modified": "2026-10-28T02:30:46.540511800Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66307.json",
"https://github.com/getgrav/grav/security/advisories/GHSA-q3qx-cp62-f6m7",
"https://nvd.nist.gov/vuln/detail/CVE-2025-66307",
"https://github.com/getgrav/grav-plugin-admin/commit/99f653296504f1d6408510dd2f6f20a45a26f9b0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-204"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66307.json"
}
},
"related_cves": [
{
"value": "CVE-2025-66307",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514538,
"published_at": "2025-12-01T21:53:43.51+00:00"
}