Skip to content
Heist/ feed
Back to feed
Medium

OpenCTI bypass of protected attribute update

Type: advisorySources: OSV

OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-24887
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 07:18 UTC · Revision 1

Source evidence

OpenCTI bypass of protected attribute update

core-osv · Original source

Published 30 Apr 2025, 18:27 UTC

OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.

osv:CVE-2025-24887
Complete source record
{
  "id": "4d0ef1a333be33e2571b8e457245e1d0e303e6664cde4c528dd7f501153b0165",
  "url": "https://osv.dev/vulnerability/CVE-2025-24887",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "OpenCTI bypass of protected attribute update",
    "summary": "OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.",
    "evidence": "osv:CVE-2025-24887",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-24887",
      "aliases": [
        "CVE-2025-24887",
        "GHSA-8262-pw2q-5qc3",
        "PYSEC-2025-178"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/opencti-platform/opencti",
              "type": "GIT",
              "events": [
                {
                  "introduced": "7d5bb142deacc08e89aadcedfe2ebcb62427dcdf"
                },
                {
                  "fixed": "38898481dc550a63d32e4e00a5a10d7b5f714e87"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "6.4.8"
                      },
                      {
                        "fixed": "6.4.10"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:citeum:opencti:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "6.4.10"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "6.4.9",
            "6.4.8"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-24887.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.938281474Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24887.json",
        "https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-8262-pw2q-5qc3",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-24887"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-284",
          "CWE-657"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24887.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-24887",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 493319,
  "published_at": "2025-04-30T18:27:24.53+00:00"
}