gobgp — security advisory
A vulnerability was identified in osrg GoBGP up to 4.3.0. Affected by this issue is the function BMPPeerUpNotification.ParseBody/BMPStatisticsReport.ParseBody of the file pkg/packet/bmp/bmp.go of the component BMP Parser. The manipulation leads to out-of-bounds read. The attack can be initiated remotely. Upgrading to version 4.4.0 can resolve this issue. The identifier of the patch is bc77597d42335c78464bc8e15a471d887bbdf260. Upgrading the affected component is recommended.
- Products
- gobgp
- Affected versions
- 3.10.0-1, 3.16.0-1, 3.19.0-1, 3.21.0-1, 3.23.0-1, 3.25.0-1, 3.27.0-1, 3.28.0-1, 3.29.0-1, 3.30.0-1, 3.31.0-1, 3.32.0-1, 3.33.0-1, 3.35.0-1, 3.36.0-1, 3.36.0-2, 4.3.0-1, 4.4.0-1, 4.5.0-1, 4.5.0-1~bpo13+1, 4.6.0-1, 4.6.0-2, 4.6.0-2~bpo13+1, 4.7.0-1, 4.7.0-1~bpo13+1, 4.8.0-1, 4.8.0-1~bpo13+1, 4.8.0-2~exp1
- Fixed versions
- 4.4.0-1
- CVEs
- CVE-2026-7737
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:53 UTC · Revision 2
Source evidence
A vulnerability was identified in osrg GoBGP up to 4.3.0. Affected by this issue is the function BMPPeerUpNotification.ParseBody/BMPStatisticsReport.ParseBody of the file pkg/packet/bmp/bmp.go of the component BMP Parser. The manipulation leads to out-of-bounds read. The attack can be initiated remotely. Upgrading to version 4.4.0 can resolve this issue. The identifier of the patch is bc77597d42335c78464bc8e15a471d887bbdf260. Upgrading the affected component is recommended.
osv:DEBIAN-CVE-2026-7737
gobgp
Fixed versions: Not specified
gobgp
Fixed versions: Not specified
gobgp
Fixed versions: 4.4.0-1
Complete source record
{
"id": "c254d75d6ffb17feafb1819d0a586db9e3927c5b2f50807e7f8c7319bf009417",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-7737",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-7737",
"summary": "A vulnerability was identified in osrg GoBGP up to 4.3.0. Affected by this issue is the function BMPPeerUpNotification.ParseBody/BMPStatisticsReport.ParseBody of the file pkg/packet/bmp/bmp.go of the component BMP Parser. The manipulation leads to out-of-bounds read. The attack can be initiated remotely. Upgrading to version 4.4.0 can resolve this issue. The identifier of the patch is bc77597d42335c78464bc8e15a471d887bbdf260. Upgrading the affected component is recommended.",
"evidence": "osv:DEBIAN-CVE-2026-7737",
"products": [
{
"name": {
"value": "gobgp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.10.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.16.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.19.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.21.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.23.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.25.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.27.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.28.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.29.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.30.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.31.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.32.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.33.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.35.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.36.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.36.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "4.3.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.4.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.5.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.5.0-1~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.6.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.6.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "4.6.0-2~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.7.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.7.0-1~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.8.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.8.0-1~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.8.0-2~exp1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "gobgp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.36.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "4.3.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.4.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.5.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.5.0-1~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.6.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.6.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "4.6.0-2~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.7.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.7.0-1~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.8.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.8.0-1~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.8.0-2~exp1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "gobgp",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.4.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "3.36.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "4.3.0-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-7737",
"aliases": [
"DEBIAN-CVE-2026-7737"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gobgp",
"purl": "pkg:deb/debian/gobgp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.10.0-1",
"3.16.0-1",
"3.19.0-1",
"3.21.0-1",
"3.23.0-1",
"3.25.0-1",
"3.27.0-1",
"3.28.0-1",
"3.29.0-1",
"3.30.0-1",
"3.31.0-1",
"3.32.0-1",
"3.33.0-1",
"3.35.0-1",
"3.36.0-1",
"3.36.0-2",
"4.3.0-1",
"4.4.0-1",
"4.5.0-1",
"4.5.0-1~bpo13+1",
"4.6.0-1",
"4.6.0-2",
"4.6.0-2~bpo13+1",
"4.7.0-1",
"4.7.0-1~bpo13+1",
"4.8.0-1",
"4.8.0-1~bpo13+1",
"4.8.0-2~exp1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-7737.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gobgp",
"purl": "pkg:deb/debian/gobgp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"3.36.0-2",
"4.3.0-1",
"4.4.0-1",
"4.5.0-1",
"4.5.0-1~bpo13+1",
"4.6.0-1",
"4.6.0-2",
"4.6.0-2~bpo13+1",
"4.7.0-1",
"4.7.0-1~bpo13+1",
"4.8.0-1",
"4.8.0-1~bpo13+1",
"4.8.0-2~exp1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-7737.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.0-1"
}
]
}
],
"package": {
"name": "gobgp",
"purl": "pkg:deb/debian/gobgp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"3.36.0-2",
"4.3.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-7737.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T10:02:15.988659444Z",
"provider": "osv",
"upstream": [
"CVE-2026-7737"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-7737"
]
},
"related_cves": [
{
"value": "CVE-2026-7737",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461426,
"published_at": "2026-05-04T07:16:01.7+00:00"
}