Apache CloudStack: Missing Privilege Check in Two-Factor Authentication Disable Flow
Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-59799
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 14:09 UTC · Revision 1
Source evidence
Apache CloudStack: Missing Privilege Check in Two-Factor Authentication Disable Flow
core-osv · Original sourcePublished 21 Aug 2026, 08:26 UTC
Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
osv:CVE-2026-59799
Complete source record
{
"id": "e1008da8f46781f330b1a9cd220ff3c3f46411d5a3c2918527593d4877c23af8",
"url": "https://osv.dev/vulnerability/CVE-2026-59799",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache CloudStack: Missing Privilege Check in Two-Factor Authentication Disable Flow",
"summary": "Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.",
"evidence": "osv:CVE-2026-59799",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-59799",
"aliases": [
"CVE-2026-59799"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/cloudstack",
"type": "GIT",
"events": [
{
"introduced": "0574087284f8b646ebc41617cfd70b3a31e3ae94"
},
{
"last_affected": "c8599040b4756034c7105806a53d2c99eb7ea0fe"
},
{
"introduced": "f9513b47bf8cda46c2cee7e31d4d662346bc7399"
},
{
"last_affected": "348ce953a99246a756b527994f7745a7be038234"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "4.18.0.0"
},
{
"last_affected": "4.20.3.0"
}
],
"source": "DESCRIPTION"
},
{
"range": [
{
"introduced": "4.21.0.0"
},
{
"last_affected": "4.22.1.0"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"4.22.1.0",
"4.20.3.0",
"4.22.0.0",
"4.21.0.0",
"4.20.1.0",
"4.20.0.0",
"4.18.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-59799.json"
}
}
],
"modified": "2026-10-28T02:30:36.052668316Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/59xxx/CVE-2026-59799.json",
"https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc",
"https://nvd.nist.gov/vuln/detail/CVE-2026-59799"
],
"provider_metadata": {
"cwe_ids": [
"CWE-269"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "4.18.0.0"
},
{
"last_affected": "4.20.3.0"
},
{
"introduced": "4.21.0.0"
},
{
"last_affected": "4.22.1.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/59xxx/CVE-2026-59799.json"
}
},
"related_cves": [
{
"value": "CVE-2026-59799",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503487,
"published_at": "2026-08-21T08:26:52.001+00:00"
}