internetarchive is vulnerable to Directory Traversal through file downloads
internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library. The file.download() method does not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. This issue is fixed in version 5.5.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-58438
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:11 UTC · Revision 1
Source evidence
internetarchive is vulnerable to Directory Traversal through file downloads
core-osv · Original sourcePublished 6 Sept 2025, 18:45 UTC
internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library. The file.download() method does not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. This issue is fixed in version 5.5.1.
osv:CVE-2025-58438
Complete source record
{
"id": "f413abd20adbe1809f2dc15a4e48b91d04c51b5c9c016bf11cf25844f8cb31a3",
"url": "https://osv.dev/vulnerability/CVE-2025-58438",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "internetarchive is vulnerable to Directory Traversal through file downloads",
"summary": "internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library. The file.download() method does not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. This issue is fixed in version 5.5.1.",
"evidence": "osv:CVE-2025-58438",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-58438",
"aliases": [
"CVE-2025-58438",
"GHSA-wx3r-v6h7-frjp",
"PYSEC-2026-357"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jjjake/internetarchive",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "73141dbdd8039731c6344f2f29f74865c91e9533"
},
{
"fixed": "cba2d459e10a9489fb35caeba0b03e80f5f5d7c2"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "5.5.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "cba2d459e10a9489fb35caeba0b03e80f5f5d7c2"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "73141dbdd8039731c6344f2f29f74865c91e9533"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v5.5.1"
}
]
}
}
],
"versions": [
"v5.5.0",
"v5.4.1",
"v5.4.0",
"v5.3.1",
"v5.3.0",
"v5.2.1",
"v5.2.0",
"v5.1.0",
"v5.0.5",
"v5.0.4",
"v5.0.3",
"v5.0.2",
"v5.0.1",
"v5.0.0",
"v4.1.0",
"v4.0.1",
"v3.7.0",
"v3.6.0",
"v3.5.0",
"v3.4.0",
"v3.3.0",
"v3.2.0",
"v3.1.0",
"v3.0.2",
"v3.0.1",
"v3.0.0",
"v2.3.0",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.9.9",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v1.9.2",
"v1.9.0",
"v1.8.5",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.7",
"v1.7.6",
"v1.7.3",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.0",
"v1.5.0",
"v1.4.0",
"v1.3.0",
"v1.2.0",
"v1.1.0",
"v1.0.10",
"v1.0.9",
"v1.0.8",
"v1.0.7",
"v1.0.5",
"v1.0.4",
"v1.0.3",
"v1.0.2",
"v1.0.1",
"v1.0.0",
"v0.9.8",
"v0.9.7",
"v0.9.6",
"v0.9.5",
"v0.9.4",
"v0.9.3",
"v0.9.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-58438.json"
}
}
],
"modified": "2026-10-28T02:30:24.745077281Z",
"provider": "osv",
"references": [
"https://github.com/jjjake/internetarchive/releases/tag/v5.5.1",
"https://lists.debian.org/debian-lts-announce/2025/09/msg00030.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58438.json",
"https://github.com/jjjake/internetarchive/security/advisories/GHSA-wx3r-v6h7-frjp",
"https://nvd.nist.gov/vuln/detail/CVE-2025-58438",
"https://github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2"
],
"provider_metadata": {
"cwe_ids": [
"CWE-22"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58438.json"
}
},
"related_cves": [
{
"value": "CVE-2025-58438",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491449,
"published_at": "2025-09-06T18:45:55.833+00:00"
}